summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2022-07-13 16:02:36 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-07-13 16:02:36 +0200
commitf6b18b53722d8ce5a3f0c961a95015a204c95b62 (patch)
tree1551f7fbe9135a295c7e63e3c43f209ac4ed4f7f /gnu/packages/emacs-xyz.scm
parente31f3e9d1c8d3a8e5886a9f0eba0f933e3e9d831 (diff)
gnu: emacs-hyperbole: Update to 8.0.0.
* gnu/packages/emacs-xyz.scm (emacs-hyperbole): Update to 8.0.0. [arguments]<#:include>: Use %default-include. <#:phases>: Add build fix. * gnu/packages/patches/emacs-hyperbole-toggle-messaging.patch: Remove file. * gnu/local.mk (dist_patch_DATA): Delete reference to removed file.
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm26
1 files changed, 13 insertions, 13 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 73a1649fd0..0cc6797024 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -594,36 +594,36 @@ uploading PlatformIO projects.")
(define-public emacs-hyperbole
(package
(name "emacs-hyperbole")
- (version "7.1.3")
+ (version "8.0.0")
(source
(origin
(method url-fetch)
(uri (string-append "https://elpa.gnu.org/packages/"
"hyperbole-" version ".tar"))
(sha256
- (base32 "0bizibn4qgxqp89fyik6p47s9hss1g932mg8k7pznn3kkhj5c8rh"))
- (patches
- (search-patches "emacs-hyperbole-toggle-messaging.patch"))))
+ (base32 "171x7jad62xd0n3xgs32dksyhn5abxj1kna0qgm65mm0v73hrv8d"))))
(build-system emacs-build-system)
(arguments
- `(#:include '("DEMO"
- "DEMO-ROLO.otl"
- "HY-ABOUT"
- "man/hkey-help.txt"
- "\\.el$"
- "\\.info$"
- "\\.kotl$")
+ `(#:include (cons* "DEMO"
+ "DEMO-ROLO.otl"
+ "HY-ABOUT"
+ "man/hkey-help.txt"
+ "\\.kotl$"
+ %default-include)
#:phases
(modify-phases %standard-phases
;; Fix build issues about missing "domainname" and "hpmap:dir-user"
- ;; parent dir.
+ ;; parent dir, and missing require in "hgnus.el" (void-function:
+ ;; var-append).
(add-after 'unpack 'fix-build
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "hypb.el"
(("/bin/domainname")
(search-input-file inputs "bin/dnsdomainname")))
(substitute* "hyperbole.el"
- (("\\(hyperb:check-dir-user\\)") ""))))
+ (("\\(hyperb:check-dir-user\\)") ""))
+ (substitute* "hgnus.el"
+ (("hmail ") "hmail hvar "))))
(add-after 'install 'install-images
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))