summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs.scm
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2017-03-10 11:00:16 +0530
committerLudovic Courtès <ludo@gnu.org>2017-03-11 12:43:36 +0100
commit55fa53491b18bac6683eefb16ab70e6dc13869ef (patch)
tree6080d554866343107dbccafd6fdd50bb98966d02 /gnu/packages/emacs.scm
parent47bdc5a173708e9138dda62dd9de0c3a9b2b03ec (diff)
gnu: Add emacs-memoize.
* gnu/packages/emacs.scm (emacs-memoize): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/emacs.scm')
-rw-r--r--gnu/packages/emacs.scm31
1 files changed, 30 insertions, 1 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 1daf8e4e68..dc2820167f 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -16,7 +16,7 @@
;;; Copyright © 2016 Alex Griffin <a@ajgrf.com>
;;; Copyright © 2016, 2017 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2016 Alex Vong <alexvong1995@gmail.com>
-;;; Copyright © 2016 Arun Isaac <arunisaac@systemreboot.net>
+;;; Copyright © 2016, 2017 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2017 Christopher Baines <mail@cbaines.net>
;;; Copyright © 2017 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2017 Clément Lassieur <clement@lassieur.org>
@@ -3852,3 +3852,32 @@ mode-line.")
"YASnippet is a template system for Emacs. It allows you to type an
abbreviation and automatically expand it into function templates.")
(license license:gpl3+)))
+
+(define-public emacs-memoize
+ (package
+ (name "emacs-memoize")
+ (version "20130421.b55eab0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/skeeto/emacs-memoize")
+ (commit "b55eab0cb6ab05d941e07b8c01f1655c0cf1dd75")))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0fjwlrdm270qcrqffvarw5yhijk656q4lam79ybhaznzj0dq3xpw"))))
+ (build-system emacs-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'install 'check
+ (lambda _
+ (zero? (system* "emacs" "-batch" "-l" "memoize.el"
+ "-l" "memoize-test.el"
+ "-f" "ert-run-tests-batch-and-exit")))))))
+ (home-page "https://github.com/skeeto/emacs-memoize")
+ (synopsis "Emacs lisp memoization library")
+ (description "@code{emacs-memoize} is an Emacs library for
+memoizing functions.")
+ (license license:unlicense)))