summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-03-17 01:18:37 -0400
committerMark H Weaver <mhw@netris.org>2018-03-17 01:18:37 -0400
commit9f388b1ee1733d84edff7f473cbcbc4ab42b7128 (patch)
tree27bd5e908f732a1cddca4b9ef93ee1981d3b0095 /gnu/packages/emacs.scm
parent2857e527de058d9e7f4efea50d381a449a1b6641 (diff)
parent9f375a4c0f55238614e047448c8e878b9829f918 (diff)
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/emacs.scm')
-rw-r--r--gnu/packages/emacs.scm45
1 files changed, 45 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 7a3e3cc257..b6fa661f0e 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -7369,3 +7369,48 @@ highlighting and indentation support.")
@uref{https://www.terraform.io/, Terraform} configuration files. Most of the
functionality is inherited from @code{hcl-mode}.")
(license license:gpl3+)))
+
+(define-public emacs-exec-path-from-shell
+ (package
+ (name "emacs-exec-path-from-shell")
+ (version "1.11")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://stable.melpa.org/packages/exec-path-from-shell-"
+ version ".el"))
+ (sha256
+ (base32
+ "03qjgb81cq1l3j54lvlf98r75vmmgd06mj6qh5wa6mz4xzp4w26r"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/purcell/exec-path-from-shell")
+ (synopsis "Get environment variables such as @var{PATH} from the shell")
+ (description
+ "This library allows the user to set Emacs @var{exec-path} and @var{PATH}
+from the shell @var{PATH}, so that @code{shell-command}, @code{compile} and
+the like work as expected on systems on which Emacs is not guaranteed to
+inherit a login shell's environment variables. It also allows other
+environment variables to be retrieved from the shell, so that Emacs will see
+the same values you get in a terminal.")
+ (license license:gpl3+)))
+
+(define-public emacs-deft
+ (package
+ (name "emacs-deft")
+ (version "0.8")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://stable.melpa.org/packages/deft-"
+ version ".el"))
+ (sha256
+ (base32
+ "1vb9cjxskc7c0yyf9pvxy1fzypg1vrcgwnjz0m3hslinsgdyig58"))))
+ (build-system emacs-build-system)
+ (home-page "https://jblevins.org/projects/deft/")
+ (synopsis "Quickly browse, filter, and edit plain text notes")
+ (description
+ "Deft is an Emacs mode for quickly browsing, filtering, and editing
+directories of plain text notes, inspired by Notational Velocity.")
+ (license license:bsd-3)))