summaryrefslogtreecommitdiff
path: root/gnu/packages/emulators.scm
diff options
context:
space:
mode:
authorChristopher Howard <christopher@librehacker.com>2020-04-18 23:31:04 -0800
committerChristopher Baines <mail@cbaines.net>2020-12-18 14:52:50 +0000
commit45c5851872d9ce6ca992be28d3e34e35e01d958a (patch)
treeb2798cd8e49c98168541f870d2805823b853aa48 /gnu/packages/emulators.scm
parentb129b43475442b1da43d8209914fee215f98aa29 (diff)
gnu: Add libticables2.
* gnu/packages/emulators.scm (libticables2): New variable. Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/emulators.scm')
-rw-r--r--gnu/packages/emulators.scm44
1 files changed, 44 insertions, 0 deletions
diff --git a/gnu/packages/emulators.scm b/gnu/packages/emulators.scm
index c2601297ac..e34679fcea 100644
--- a/gnu/packages/emulators.scm
+++ b/gnu/packages/emulators.scm
@@ -12,6 +12,7 @@
;;; Copyright © 2019 Pierre Neidhardt <mail@ambrevar.xyz>
;;; Copyright © 2019 David Wilson <david@daviwil.com>
;;; Copyright © 2020 Jakub Kądziołka <kuba@kadziolka.net>
+;;; Copyright © 2020 Christopher Howard <christopher@librehacker.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -39,6 +40,7 @@
#:use-module (gnu packages algebra)
#:use-module (gnu packages assembly)
#:use-module (gnu packages audio)
+ #:use-module (gnu packages autogen)
#:use-module (gnu packages autotools)
#:use-module (gnu packages base)
#:use-module (gnu packages boost)
@@ -1380,6 +1382,48 @@ just replaces the executables shipped with the games, allowing you to
play them on systems for which they were never designed!")
(license license:gpl2+)))
+(define-public libticables2
+ (package
+ (name "libticables2")
+ (version "1.3.5")
+ (source (origin
+ (method url-fetch)
+ (uri "https://www.ticalc.org/pub/unix/tilibs.tar.gz")
+ (sha256
+ (base32
+ "07cfwwlidgx4fx88whnlch6y1342x16h15lkvkkdlp2y26sn2yxg"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:configure-flags (list "--enable-libusb10")
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'unpack
+ (lambda* (#:key source #:allow-other-keys)
+ (invoke "tar" "xvkf" source)
+ (invoke "tar" "xvkf"
+ (string-append "tilibs2/libticables2-"
+ ,version ".tar.bz2"))
+ (chdir (string-append "libticables2-" ,version))
+ #t)))))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("autogen" ,autogen)
+ ("automake" ,automake)
+ ("gettext" ,gnu-gettext)
+ ("libtool" ,libtool)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("glib" ,glib)
+ ("libusb" ,libusb)))
+ (synopsis "Link cable library for TI calculators")
+ (description
+ "This package contains libticables, a library for operations on
+@acronym{TI, Texas Instruments} calculator link cables.
+
+This is a part of the TiLP project.")
+ (home-page "http://lpg.ticalc.org/prj_tilp/")
+ (license license:gpl2+)))
+
(define-public mame
(package
(name "mame")