summaryrefslogtreecommitdiff
path: root/gnu/packages/emulators.scm
diff options
context:
space:
mode:
authorKei Kebreau <kkebreau@posteo.net>2021-02-10 13:19:53 -0500
committerKei Kebreau <kkebreau@posteo.net>2021-02-10 13:36:26 -0500
commit6d36cacead0058632da29b7c8af0158233a14e23 (patch)
treebe6154ec2cbf5c28ac404c910235342dea03016a /gnu/packages/emulators.scm
parentaf55e2aad6abaf1efb60366796fcfb7867e296fb (diff)
gnu: dolphin-emu: Update to 5.0-13178.
* gnu/packages/emulators.scm (dolphin-emu): Update to 5.0-13178. [arguments]: Simplify 'generate-fonts&hardcore-libvulkan-path phase.
Diffstat (limited to 'gnu/packages/emulators.scm')
-rw-r--r--gnu/packages/emulators.scm16
1 files changed, 8 insertions, 8 deletions
diff --git a/gnu/packages/emulators.scm b/gnu/packages/emulators.scm
index 382ddbcf1b..05cd0d65c5 100644
--- a/gnu/packages/emulators.scm
+++ b/gnu/packages/emulators.scm
@@ -132,9 +132,11 @@
(license license:gpl2)))
;; Building from recent Git because the official 5.0 release no longer builds.
+;; Following commits and revision numbers of beta versions listed at
+;; https://dolphin-emu.org/download/.
(define-public dolphin-emu
- (let ((commit "3e4bf57c696ed1e4f465075ae311653de2cd33b0")
- (revision "8"))
+ (let ((commit "a34823df61df65168aa40ef5e82e44defd4a0138")
+ (revision "13178"))
(package
(name "dolphin-emu")
(version (git-version "5.0" revision commit))
@@ -160,7 +162,7 @@
#t))
(sha256
(base32
- "0mscspwd4k635b0857253ic55idlv2jvjdljssbryf8kd1ikwlhs"))))
+ "0j6hnj60iai366kl0kdbn1jkwc183l02g65mp2vq4qb2yd4399l1"))))
(build-system cmake-build-system)
(arguments
'(#:tests? #f
@@ -183,11 +185,9 @@
(copy-file "font_western.bin" "../Data/Sys/GC/font_western.bin")
(chdir "..")
(substitute* "Source/Core/VideoBackends/Vulkan/VulkanLoader.cpp"
- (("\"vulkan\", 1") (string-append "\"vulkan\"")))
- (substitute* "Source/Core/VideoBackends/Vulkan/VulkanLoader.cpp"
- (("\"vulkan\"") (string-append "\"" libvulkan "\"")))
- (substitute* "Source/Core/VideoBackends/Vulkan/VulkanLoader.cpp"
- (("Common::DynamicLibrary::GetVersionedFilename") ""))
+ (("\"vulkan\", 1") (string-append "\"vulkan\""))
+ (("\"vulkan\"") (string-append "\"" libvulkan "\""))
+ (("Common::DynamicLibrary::GetVersionedFilename") ""))
#t))))
;; The FindGTK2 cmake script only checks hardcoded directories for