summaryrefslogtreecommitdiff
path: root/gnu/packages/enchant.scm
diff options
context:
space:
mode:
authorRaghav Gururajan <raghavgururajan@disroot.org>2020-05-30 15:28:31 -0400
committerDanny Milosavljevic <dannym@scratchpost.org>2020-08-18 22:54:05 +0200
commit5c5dfb6d9eaeeac529d00834f17ad1a199bee414 (patch)
tree1ee8f964f11299895cf87706a50832ff7536112f /gnu/packages/enchant.scm
parente445ae9ae13dc33f3770324c58cb91cd89185846 (diff)
gnu: Add nuspell.
* gnu/packages/enchant.scm (nuspell): New variable. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
Diffstat (limited to 'gnu/packages/enchant.scm')
-rw-r--r--gnu/packages/enchant.scm43
1 files changed, 43 insertions, 0 deletions
diff --git a/gnu/packages/enchant.scm b/gnu/packages/enchant.scm
index ff4fc03363..4f582f1bff 100644
--- a/gnu/packages/enchant.scm
+++ b/gnu/packages/enchant.scm
@@ -22,17 +22,60 @@
(define-module (gnu packages enchant)
#:use-module (gnu packages)
#:use-module (gnu packages aspell)
+ #:use-module (gnu packages boost)
#:use-module (gnu packages check)
#:use-module (gnu packages glib)
+ #:use-module (gnu packages icu4c)
#:use-module (gnu packages libreoffice)
+ #:use-module (gnu packages man)
+ #:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages version-control)
#:use-module (guix packages)
+ #:use-module (guix git-download)
#:use-module (guix download)
+ #:use-module (guix build-system cmake)
#:use-module (guix build-system gnu)
#:use-module (guix build-system python)
#:use-module (guix licenses)
#:use-module (srfi srfi-1))
+(define-public nuspell
+ (package
+ (name "nuspell")
+ (version "3.1.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/nuspell/nuspell.git")
+ (commit
+ (string-append "v" version))))
+ (file-name
+ (git-file-name name version))
+ (sha256
+ (base32 "18zz3rdzlb3knzsd98vw8cfyb3iq0ilipnlz7rz10zgb5ail73s2"))))
+ (build-system cmake-build-system)
+ (native-inputs
+ `(("catch" ,catch-framework2)
+ ("git" ,git-minimal)
+ ("perl" ,perl)
+ ;;FIX-ME: Building with ronn fails.
+ ;;("ronn" ,ronn)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("boost" ,boost)))
+ (propagated-inputs
+ `(("icu4c" ,icu4c)))
+ (synopsis "Fast and safe spellchecking C++ library")
+ (description "Nuspell is a fast and safe spelling checker software
+program. It is designed for languages with rich morphology and complex word
+compounding. Nuspell is written in modern C++ and it supports Hunspell
+dictionaries.")
+ (home-page "https://nuspell.github.io/")
+ (license lgpl3+)))
+
(define-public enchant
(package
(name "enchant")