summaryrefslogtreecommitdiff
path: root/gnu/packages/engineering.scm
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2023-04-22 12:24:32 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2023-04-22 12:57:03 +0200
commit5569971659ff988c27ea868756e7da935f42dea5 (patch)
treef7d58e9194623ed6cd8c5169a8a50c6d4092cdff /gnu/packages/engineering.scm
parent6c91f65d09debbb8578047e4b5669b8ba4c73888 (diff)
gnu: prusa-slicer: Update to 2.5.2.
* gnu/packages/patches/prusa-slicer-boost-fixes.patch: New file. * gnu/packages/patches/prusa-slicer-fix-tests.patch: New file. * gnu/packages/patches/prusa-slicer-with-cereal-1.3.1.patch: New file. * gnu/local.mk (dist_patch_DATA): Register them. * gnu/packages/engineering.scm (prusa-slicer): Update to 2.5.2. [source]: Use patches. [inputs]: Replace cereal-1.3.0 by cereal.
Diffstat (limited to 'gnu/packages/engineering.scm')
-rw-r--r--gnu/packages/engineering.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 66f3769e68..44092e77c5 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -3508,7 +3508,7 @@ visualization, matrix manipulation.")
(define-public prusa-slicer
(package
(name "prusa-slicer")
- (version "2.5.0")
+ (version "2.5.2")
(source
(origin
(method git-fetch)
@@ -3517,7 +3517,10 @@ visualization, matrix manipulation.")
(url "https://github.com/prusa3d/PrusaSlicer")
(commit (string-append "version_" version))))
(file-name (git-file-name name version))
- (sha256 (base32 "17ic92ww2ny0frxyv7ajwdwa0fq70ygq562ik8sh94jx67jvxdy0"))
+ (sha256 (base32 "02qcrw3fa0d8ldbp73hp14l1qxbp3f4608j4csc07ny00ra42151"))
+ (patches (search-patches "prusa-slicer-boost-fixes.patch"
+ "prusa-slicer-fix-tests.patch"
+ "prusa-slicer-with-cereal-1.3.1.patch"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -3553,7 +3556,7 @@ visualization, matrix manipulation.")
(list pkg-config))
(inputs
(list boost
- cereal-1.3.0
+ cereal
cgal
curl
dbus