summaryrefslogtreecommitdiff
path: root/gnu/packages/engineering.scm
diff options
context:
space:
mode:
authorMalte Frank Gerdes <malte.f.gerdes@gmail.com>2022-04-07 15:53:35 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2022-04-07 15:54:02 +0200
commit8d2493dda175213801741704e3c0e00d85edce07 (patch)
treec984bd2bc2d3f9c9d4afd490ab237010f30d19e0 /gnu/packages/engineering.scm
parent742a7d897f26797b705a32f72628f2f3b2770940 (diff)
gnu: Add cura-binary-data.
* gnu/packages/engineering.scm (cura-binary-data): New variable. Co-authored-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu/packages/engineering.scm')
-rw-r--r--gnu/packages/engineering.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 36695fcb92..d8370f0cb0 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -3332,3 +3332,32 @@ processing 3D models into 3D printing instruction for Ultimaker and other
GCode based 3D printers. It is part of the larger open source project called
Cura.")
(license license:agpl3+)))
+
+(define-public cura-binary-data
+ (package
+ (name "cura-binary-data")
+ (version "4.13.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Ultimaker/cura-binary-data")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "11dra399adky7jxpaqqk1swrg5y3cc1086l54c3injg3ccgrvwik"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ ;; Remove Windows executables and prebuilt firmware files.
+ (delete-file-recursively "cura/resources/firmware")
+ (delete-file-recursively "windows")))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f ; No test suite.
+ #:configure-flags '("-DENABLE_FIRMWARE_INSTALL=OFF")))
+ (home-page "https://github.com/Ultimaker/cura-binary-data")
+ (synopsis "Binary data for Cura, like compiled translations")
+ (description "This package contains binary data for Cura releases, like
+compiled translations. Prebuilt Firmware files are removed.")
+ (license license:agpl3)))