summaryrefslogtreecommitdiff
path: root/gnu/packages/enlightenment.scm
diff options
context:
space:
mode:
authorTomáš Čech <sleep_walker@suse.cz>2015-02-26 01:26:41 +0100
committerTomáš Čech <sleep_walker@suse.cz>2015-03-03 13:04:37 +0100
commitdf2b053af89cf5d5a7216249e47a2b5989b27ea1 (patch)
tree2a415a7d41332bfdd6329e0495972ca054fd84fd /gnu/packages/enlightenment.scm
parentcfa0468317d8bc0135bf9de92052dbabecd021d7 (diff)
gnu: Add terminology.
* gnu/packages/enlightenment.scm (terminology): New variable.
Diffstat (limited to 'gnu/packages/enlightenment.scm')
-rw-r--r--gnu/packages/enlightenment.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/enlightenment.scm b/gnu/packages/enlightenment.scm
index 77ebd2a237..1b139a8d67 100644
--- a/gnu/packages/enlightenment.scm
+++ b/gnu/packages/enlightenment.scm
@@ -206,3 +206,30 @@ files in Evas (EFL canvas library).")
and applications allowing to natively play video files through Emotion.
The only supported now is VLC.")
(license license:bsd-2)))
+
+(define-public terminology
+ (package
+ (name "terminology")
+ (version "0.8.0")
+ (source (origin
+ (method url-fetch)
+ (uri
+ (string-append
+ "http://download.enlightenment.org/rel/apps/terminology/terminology-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "0a767ixackzmhb2awrhjy7q6vsivsd54wc434i617xiw095x843s"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("efl" ,efl)
+ ("elementary" ,elementary)))
+ (home-page "http://www.enlightenment.org")
+ (synopsis "Powerful terminal emulator based on EFL")
+ (description
+ "Terminology is fast and feature rich terminal emulator. It is solely
+based on Enlightenment Foundation Libraries. It supports multiple tabs, UTF-8,
+URL and local path detection, themes, popup based content viewer for non-text
+contents and more.")
+ (license license:bsd-2)))