summaryrefslogtreecommitdiff
path: root/gnu/packages/file-systems.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-12-22 04:57:12 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2021-12-29 02:56:47 +0100
commit1a6ca068275ffc69b5ba25ff7f1f829a01057681 (patch)
tree34518c56b753a3047b8c7c32f364f35fc6d3abfc /gnu/packages/file-systems.scm
parent0f9bc3a8ad4d3549812bf782a80544a52a36b682 (diff)
gnu: bcachefs-tools/static: Use G-expressions.
* gnu/packages/file-systems.scm (bcachefs-tools/static)[arguments]: Rewrite as G-expressions.
Diffstat (limited to 'gnu/packages/file-systems.scm')
-rw-r--r--gnu/packages/file-systems.scm20
1 files changed, 10 insertions, 10 deletions
diff --git a/gnu/packages/file-systems.scm b/gnu/packages/file-systems.scm
index a55259acbb..7628f2c804 100644
--- a/gnu/packages/file-systems.scm
+++ b/gnu/packages/file-systems.scm
@@ -484,16 +484,16 @@ performance and other characteristics.")
(license license:gpl2+))))
(define-public bcachefs-tools/static
- (package
- (inherit bcachefs-tools)
- (name "bcachefs-tools-static")
- (arguments
- (substitute-keyword-arguments (package-arguments bcachefs-tools)
- ((#:make-flags make-flags)
- `(append ,make-flags
- (list "LDFLAGS=-static")))
- ((#:phases phases)
- `(modify-phases ,phases
+ (package
+ (inherit bcachefs-tools)
+ (name "bcachefs-tools-static")
+ (arguments
+ (substitute-keyword-arguments (package-arguments bcachefs-tools)
+ ((#:make-flags make-flags)
+ #~(append #$make-flags
+ (list "LDFLAGS=-static")))
+ ((#:phases phases)
+ #~(modify-phases #$phases
(add-after 'unpack 'skip-shared-library
(lambda _
(substitute* "Makefile"