summaryrefslogtreecommitdiff
path: root/gnu/packages/file-systems.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2023-07-23 02:00:00 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2023-07-23 02:00:00 +0200
commitef37cff046e5593b560e18d6bb77c8f39ee417cd (patch)
treec426a8716c3b371fa1ffb222dc1653c5cb96a2a5 /gnu/packages/file-systems.scm
parent789f7e9a3d37135d22d0a84c987fe3877131fd06 (diff)
gnu: apfs-fuse: Update to 0.0.0-2.66b86bd.
* gnu/packages/file-systems.scm (apfs-fuse): Update to 0.0.0-2.66b86bd. [arguments]: Remove anti-fuse@3 configure flag. Don't install a static library. Don't explicitly return #t from phases. [inputs]: Upgrade fuse-2 to fuse (3).
Diffstat (limited to 'gnu/packages/file-systems.scm')
-rw-r--r--gnu/packages/file-systems.scm16
1 files changed, 5 insertions, 11 deletions
diff --git a/gnu/packages/file-systems.scm b/gnu/packages/file-systems.scm
index 8d9ed917aa..0fa492b870 100644
--- a/gnu/packages/file-systems.scm
+++ b/gnu/packages/file-systems.scm
@@ -1158,9 +1158,8 @@ network. LIBNFS offers three different APIs, for different use :
))))
(define-public apfs-fuse
- ;; Later versions require FUSE 3.
- (let ((commit "7b89418e8dc27103d3c4f8fa348086ffcd634c17")
- (revision "1"))
+ (let ((commit "66b86bd525e8cb90f9012543be89b1f092b75cf3")
+ (revision "2"))
(package
(name "apfs-fuse")
(version (git-version "0.0.0" revision commit))
@@ -1171,14 +1170,11 @@ network. LIBNFS offers three different APIs, for different use :
(recursive? #t) ; for lzfse
(commit commit)))
(sha256
- (base32
- "0x2siy3cmnm9wsdfazg3xc8r3kbg73gijmnn1vjw33pp71ckylxr"))
+ (base32 "0f63slyzv8fbgshpzrx2g01x9h73g5yvh5kis4yazl19fjm2b05r"))
(file-name (git-file-name name version))))
(build-system cmake-build-system)
(arguments
`(#:tests? #f ; No test suite
- #:configure-flags
- '("-DUSE_FUSE3=OFF")
#:phases
(modify-phases %standard-phases
;; No 'install' target in CMakeLists.txt
@@ -1192,11 +1188,9 @@ network. LIBNFS offers three different APIs, for different use :
(install-file "apfs-dump" bin)
(install-file "apfs-dump-quick" bin)
(install-file "apfs-fuse" bin)
- (install-file "libapfs.a" lib)
- (install-file "../source/README.md" doc)
- #t))))))
+ (install-file "../source/README.md" doc)))))))
(inputs
- (list bzip2 fuse-2 zlib))
+ (list bzip2 fuse zlib))
(synopsis "Read-only FUSE driver for the APFS file system")
(description "APFS-FUSE is a read-only FUSE driver for the @dfn{Apple File
System} (APFS). It is currently in an experimental state — it may not be able