summaryrefslogtreecommitdiff
path: root/gnu/packages/finance.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-04-11 00:10:23 +0200
committerMarius Bakke <mbakke@fastmail.com>2020-04-11 00:10:23 +0200
commitbdb90df764661c11b37c988ea129c8e7a01b1889 (patch)
treec320b71b136bfcc5e5ec949279a05c8134fb0cca /gnu/packages/finance.scm
parentb859a1bf7953eb98668cb11b459cde48b0dce991 (diff)
parent8ec9c5fd880be35fe322b0d4dbc69bd2c6c89ef1 (diff)
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/finance.scm')
-rw-r--r--gnu/packages/finance.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index ea1fcbe9d4..c639a9a562 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -17,6 +17,7 @@
;;; Copyright © 2019 Sebastian Schott <sschott@mailbox.org>
;;; Copyright © 2020 Kei Kebreau <kkebreau@posteo.net>
;;; Copyright © 2020 Christopher Lemmer Webber <cwebber@dustycloud.org>
+;;; Copyright © 2020 Tom Zander <tomz@freedommail.ch>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1401,6 +1402,44 @@ electronic cash system. This package provides a command line client and
a Qt GUI.")
(license license:expat)))
+(define-public fulcrum
+ (package
+ (name "fulcrum")
+ (version "1.0.5b")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://gitlab.com/FloweeTheHub/fulcrum/-/archive/v"
+ version "/fulcrum-v" version ".tar.gz"))
+ (sha256
+ (base32 "1c1hkik8avill8ha33g76rk4b03j5ac8wiml69q4jav7a63ywgfy"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ ;; Call qmake instead of configure to create a Makefile.
+ (replace 'configure
+ (lambda _
+ (invoke
+ "qmake"
+ (string-append "PREFIX=" %output)
+ "features="))))))
+ (native-inputs
+ `(("qttools" ,qttools)))
+ (inputs
+ `(("python" ,python)
+ ("qtbase" ,qtbase)
+ ("rocksdb" ,rocksdb)
+ ("zlib" ,zlib)))
+ (home-page "https://gitlab.com/FloweeTheHub/fulcrum/")
+ (synopsis "Fast and nimble SPV server for Bitcoin Cash")
+ (description
+ "Flowee Fulcrum is a server that is the back-end for @acronym{SPV,
+Simplified Payment Verification} wallets, it provides the full API for those
+walets in a fast and small server. The full data is stored in a full node,
+like Flowee the Hub, which Fulcrum connects to over RPC.")
+ (license license:gpl3+)))
+
(define-public beancount
(package
(name "beancount")