summaryrefslogtreecommitdiff
path: root/gnu/packages/finance.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-02-02 22:08:31 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-03-19 09:31:08 +0000
commitc8fdd007f9430be7310b37153c92252b78bdac17 (patch)
tree736096570105ce89c09d6cae9adc6e0d0f2689d3 /gnu/packages/finance.scm
parentf12172612d0d3473cbf11ed9ea1512a91f18ce9e (diff)
gnu: beancount: Adjust package style.
* gnu/packages/finance.scm (beancount) [arguments]: Use G-expressions. <#:phases>: Remove trailing #f from lambda. Change-Id: I3a248c0b233b0f4d73dcc01f269cfb0a12fe06ff
Diffstat (limited to 'gnu/packages/finance.scm')
-rw-r--r--gnu/packages/finance.scm22
1 files changed, 11 insertions, 11 deletions
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index e8491713bb..32c507cd85 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -1976,17 +1976,17 @@ that allows you to run services and through them access the Bitcoin Cash network
(patches (search-patches "beancount-disable-googleapis-fonts.patch"))))
(build-system python-build-system)
(arguments
- `(#:tests? #f ; Says test is missing, not sure why
- #:phases
- (modify-phases %standard-phases
- ;; Not importing the googleapis package for now
- (add-after 'unpack 'ignore-googleapis
- (lambda _
- (substitute* "setup.py"
- (("'google-api-python-client',") ""))
- #t))
- ;; No module named 'google_auth_oauthlib'
- (delete 'sanity-check))))
+ (list
+ #:tests? #f ; Says test is missing, not sure why
+ #:phases
+ #~(modify-phases %standard-phases
+ ;; Not importing the googleapis package for now
+ (add-after 'unpack 'ignore-googleapis
+ (lambda _
+ (substitute* "setup.py"
+ (("'google-api-python-client',") ""))))
+ ;; No module named 'google_auth_oauthlib'
+ (delete 'sanity-check))))
(inputs
(list python-beautifulsoup4
python-bottle