summaryrefslogtreecommitdiff
path: root/gnu/packages/fonts.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-06-06 13:03:21 +0300
committerEfraim Flashner <efraim@flashner.co.il>2024-06-06 15:10:40 +0300
commit9eef9cd8ade71fd25e5c407c17e009d421968992 (patch)
tree1d228f317aa6870aa73c53198989e23f0c2efd38 /gnu/packages/fonts.scm
parent825fcecb7adc823c29585f702f2b44056b0ffc11 (diff)
gnu: font-gnu-freefont: Build with newer fontforge.
* gnu/packages/fonts.scm (font-gnu-freefont)[source]: Add patch. Add snippet to remove processed python code. * gnu/packages/patches/font-gnu-freefont-python3-compat.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. Change-Id: I042697aba1ca4ff7448cd4fb62268e62fd883bc2
Diffstat (limited to 'gnu/packages/fonts.scm')
-rw-r--r--gnu/packages/fonts.scm13
1 files changed, 7 insertions, 6 deletions
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index a5c8cfadce..cab12d6527 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -11,7 +11,7 @@
;;; Copyright © 2016 Jookia <166291@gmail.com>
;;; Copyright © 2016 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2016 Dmitry Nikolaev <cameltheman@gmail.com>
-;;; Copyright © 2016-2023 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016-2024 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016, 2020 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2016 Toni Reina <areina@riseup.net>
;;; Copyright © 2017–2022 Tobias Geerinckx-Rice <me@tobias.gr>
@@ -88,6 +88,7 @@
#:use-module (guix build-system gnu)
#:use-module (guix build-system meson)
#:use-module (guix build-system trivial)
+ #:use-module (gnu packages)
#:use-module (gnu packages c)
#:use-module (gnu packages base)
#:use-module (gnu packages bash)
@@ -436,8 +437,6 @@ font is provided in the OpenType font (OTF) format.")
(define-public font-gnu-freefont
(package
(name "font-gnu-freefont")
- ;; Note: Remove the special FontForge input and package once the 2020
- ;; release is out.
(version "20120503")
(source (origin
(method url-fetch)
@@ -445,7 +444,10 @@ font is provided in the OpenType font (OTF) format.")
version ".tar.gz"))
(sha256
(base32
- "0yk58blhcd4hm7nyincmqq4jrzjjk82wif2zmk1l3y2m4vif4qhd"))))
+ "0yk58blhcd4hm7nyincmqq4jrzjjk82wif2zmk1l3y2m4vif4qhd"))
+ (patches (search-patches "font-gnu-freefont-python3-compat.patch"))
+ (snippet
+ '(begin (delete-file "tools/generate/buildutils.pyc")))))
(build-system gnu-build-system)
(arguments
`(#:phases (modify-phases %standard-phases
@@ -491,8 +493,7 @@ font is provided in the OpenType font (OTF) format.")
(lambda (file) (string-suffix? "woff" file))
(find-files "." "")))))))
#:test-target "tests"))
- ;; FreeFont anno 2012 requires a FontForge built with Python 2.
- (native-inputs (list fontforge-20190801))
+ (native-inputs (list fontforge))
(home-page "https://www.gnu.org/software/freefont/")
(synopsis "Unicode-encoded outline fonts")
(description