summaryrefslogtreecommitdiff
path: root/gnu/packages/fontutils.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-03-17 11:22:34 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-03-18 19:23:46 +0100
commit0a502c8c9bd07bfdc24aac6f3bdec939e0d9aef4 (patch)
tree83af9769e87896d7e22d607a53360bf703012b33 /gnu/packages/fontutils.scm
parent850093ac24f92ae805a2ee90681d1e4cb01ff8eb (diff)
gnu: fontforge: Update to 20200314.
* gnu/packages/fontutils.scm (fontforge): Update to 20200314. [source](uri): Adjust for new tar.xz download. [native-inputs]: Remove AUTOCONF, AUTOMAKE and LIBTOOL. [build-system]: Switch to CMAKE-BUILD-SYSTEM. [arguments]: Add #:configure-flags. Remove phase 'fix-linking-with-python3.8', add phase 'do-not-override-RPATH'.
Diffstat (limited to 'gnu/packages/fontutils.scm')
-rw-r--r--gnu/packages/fontutils.scm37
1 files changed, 16 insertions, 21 deletions
diff --git a/gnu/packages/fontutils.scm b/gnu/packages/fontutils.scm
index 8e82112f1b..6784dc7cf6 100644
--- a/gnu/packages/fontutils.scm
+++ b/gnu/packages/fontutils.scm
@@ -569,23 +569,17 @@ definitions.")
(define-public fontforge
(package
(name "fontforge")
- (version "20190801")
+ (version "20200314")
(source (origin
(method url-fetch)
(uri (string-append
"https://github.com/fontforge/fontforge/releases/download/"
- version "/fontforge-" version ".tar.gz"))
+ version "/fontforge-" version ".tar.xz"))
(sha256
- (base32 "0lh8yx01asbzxm6car5cfi64njh5p4lxc7iv8dldr5rwg357a86r"))))
- (build-system gnu-build-system)
+ (base32 "0qf88wd6riycq56d24brybyc93ns74s0nyyavm43zp2kfcihn6fd"))))
+ (build-system cmake-build-system)
(native-inputs
- `(("pkg-config" ,pkg-config)
-
- ;; TODO: Remove these inputs and the 'fix-linking-with-python-3.8' phase
- ;; below when updating fontforge.
- ("autoconf" ,autoconf)
- ("automake" ,automake)
- ("libtool" ,libtool)))
+ `(("pkg-config" ,pkg-config)))
(inputs `(("cairo" ,cairo)
("fontconfig" ,fontconfig) ;dlopen'd
("freetype" ,freetype)
@@ -608,18 +602,19 @@ definitions.")
("python" ,python)
("zlib" ,zlib)))
(arguments
- '(#:phases
+ '(#:configure-flags '(;; TODO: Provide GTK+ for the Wayland-friendly GDK
+ ;; backend, instead of the legacy X11 backend.
+ ;; Currently it introduces a circular dependency.
+ "-DENABLE_X11=ON")
+ #:phases
(modify-phases %standard-phases
- (add-before 'bootstrap 'fix-linking-with-python-3.8
+ (add-after 'unpack 'do-not-override-RPATH
(lambda _
- ;; Applications that embed the Python interpreter are supposed to
- ;; use the new "python-3.8-embed.pc" pkg-config file starting with
- ;; Python 3.8. Adjust the build system accordingly.
- (substitute* "m4/fontforge_arg_enable.m4"
- (("python-\"\\$\\{PYTHON_VERSION\\}\"" all)
- (string-append all "-embed")))
- ;; Delete the configure script in order to force autoreconf.
- (delete-file "configure")
+ ;; Do not attempt to set a default RPATH, as our ld-wrapper
+ ;; already does the right thing.
+ (substitute* "CMakeLists.txt"
+ (("^set_default_rpath\\(\\)")
+ ""))
#t))
(add-after 'install 'set-library-path
(lambda* (#:key inputs outputs #:allow-other-keys)