summaryrefslogtreecommitdiff
path: root/gnu/packages/freedesktop.scm
diff options
context:
space:
mode:
authormuradm <mail@muradm.net>2022-06-15 12:17:40 +0300
committerLars-Dominik Braun <ldb@leibniz-psychology.org>2022-06-17 10:30:42 +0200
commit167b8f29b3679a23bb20f5ed4181738c389d9d89 (patch)
treea68b13d1d6b02d364b04453269c7c148fdd2a32b /gnu/packages/freedesktop.scm
parent530e0f02606a0e04818bdd792bb5239f7ee9e637 (diff)
gnu: admin: Add libseat 0.8.0 and move seatd.
* gnu/packages/admin.scm (libseat): New variable * gnu/packages/admin.scm (seatd): New variable * gnu/packages/freedesktop.scm (seatd): Remove variable * gnu/packages/wm.scm (wlroots): Replace seatd input with libseat Signed-off-by: Lars-Dominik Braun <ldb@leibniz-psychology.org>
Diffstat (limited to 'gnu/packages/freedesktop.scm')
-rw-r--r--gnu/packages/freedesktop.scm29
1 files changed, 0 insertions, 29 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 8834e7b839..c54ce1cf31 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -849,35 +849,6 @@ GNOME Shell. The @command{localectl} command-line tool allows you to interact
with localed. This package is extracted from the broader systemd package.")
(license license:lgpl2.1+)))
-(define-public seatd
- (package
- (name "seatd")
- (version "0.5.0")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://git.sr.ht/~kennylevinsen/seatd")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1kglq8v4rnr3415mfaghyv2s2f8mxsy5s881gmm2908ig4n4j297"))))
- (build-system meson-build-system)
- (arguments
- `(#:configure-flags '("-Dlogind=enabled")))
- (native-inputs
- (list pkg-config scdoc))
- (propagated-inputs
- (list elogind))
- (home-page "https://sr.ht/~kennylevinsen/seatd")
- (synopsis "Seat management daemon and library")
- (description
- "This package provides a minimal seat management daemon whose task is to
-mediate access to shared devices, such as graphics and input, for applications
-that require it. It also provides a universal seat management library that
-allows applications to use whatever seat management is available.")
- (license license:expat)))
-
(define-public packagekit
(package
(name "packagekit")