summaryrefslogtreecommitdiff
path: root/gnu/packages/freedesktop.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-11-01 17:43:50 +0100
committerLudovic Courtès <ludo@gnu.org>2015-11-01 17:56:47 +0100
commit5905114a10572e1858b653bc3fbf21e581344c75 (patch)
treed3d241769c2e04ee7df22373997140c7e9f12d98 /gnu/packages/freedesktop.scm
parent222e3319bd9e942070be57933a50996e3c73cb39 (diff)
gnu: udisks: Find the 'mount' command.
* gnu/packages/freedesktop.scm (udisks)[inputs]: Add UTIL-LINUX. [arguments]: Add 'set-mount-file-name' phase.
Diffstat (limited to 'gnu/packages/freedesktop.scm')
-rw-r--r--gnu/packages/freedesktop.scm16
1 files changed, 14 insertions, 2 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index ee94db440a..b428041423 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -343,7 +343,8 @@ Analysis and Reporting Technology) functionality.")
`(("acl" ,acl)
("libatasmart" ,libatasmart)
("libgudev" ,libgudev)
- ("polkit" ,polkit)))
+ ("polkit" ,polkit)
+ ("util-linux" ,util-linux)))
(arguments
`(#:tests? #f ; requiring system message dbus
#:configure-flags
@@ -360,7 +361,18 @@ Analysis and Reporting Technology) functionality.")
(("girdir = .*")
"girdir = $(datadir)/gir-1.0\n")
(("typelibsdir = .*")
- "typelibsdir = $(libdir)/girepository-1.0\n")))))))
+ "typelibsdir = $(libdir)/girepository-1.0\n"))))
+ (add-after 'install 'set-mount-file-name
+ (lambda* (#:key outputs inputs #:allow-other-keys)
+ ;; Tell 'udisksd' where to find the 'mount' command.
+ (let ((out (assoc-ref outputs "out"))
+ (utils (assoc-ref inputs "util-linux")))
+ (wrap-program (string-append out "/libexec/udisks2/udisksd")
+ `("PATH" ":" prefix
+ (,(string-append utils "/bin") ;for 'mount'
+ "/run/current-system/profile/bin"
+ "/run/current-system/profile/sbin")))
+ #t))))))
(home-page "http://www.freedesktop.org/wiki/Software/udisks/")
(synopsis "Disk manager service")
(description