summaryrefslogtreecommitdiff
path: root/gnu/packages/freedesktop.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2022-06-22 18:48:00 +0200
committerLudovic Courtès <ludo@gnu.org>2022-06-22 18:48:00 +0200
commit8655a714457dbf1cde45979507012d9515614028 (patch)
tree7712625328f45794ccda9baa730a4825bb2efb47 /gnu/packages/freedesktop.scm
parenta589049e141588ebcf4079116e378d60b779f6b4 (diff)
parent2af3f5eef045f7d177cc394c89be069bac895688 (diff)
Merge branch master into core-updates
Diffstat (limited to 'gnu/packages/freedesktop.scm')
-rw-r--r--gnu/packages/freedesktop.scm56
1 files changed, 17 insertions, 39 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 5308eb8bcc..36b792ccf0 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -2,7 +2,7 @@
;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2015 Sou Bunnbu <iyzsong@gmail.com>
;;; Copyright © 2015, 2017 Andy Wingo <wingo@pobox.com>
-;;; Copyright © 2015-2017, 2019, 2021 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2015-2017, 2019, 2021-2022 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2015, 2017, 2018, 2019, 2021 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015 David Hashe <david.hashe@dhashe.com>
;;; Copyright © 2016, 2017, 2019, 2021, 2022 Efraim Flashner <efraim@flashner.co.il>
@@ -851,35 +851,6 @@ GNOME Shell. The @command{localectl} command-line tool allows you to interact
with localed. This package is extracted from the broader systemd package.")
(license license:lgpl2.1+)))
-(define-public seatd
- (package
- (name "seatd")
- (version "0.5.0")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://git.sr.ht/~kennylevinsen/seatd")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1kglq8v4rnr3415mfaghyv2s2f8mxsy5s881gmm2908ig4n4j297"))))
- (build-system meson-build-system)
- (arguments
- `(#:configure-flags '("-Dlogind=enabled")))
- (native-inputs
- (list pkg-config scdoc))
- (propagated-inputs
- (list elogind))
- (home-page "https://sr.ht/~kennylevinsen/seatd")
- (synopsis "Seat management daemon and library")
- (description
- "This package provides a minimal seat management daemon whose task is to
-mediate access to shared devices, such as graphics and input, for applications
-that require it. It also provides a universal seat management library that
-allows applications to use whatever seat management is available.")
- (license license:expat)))
-
(define-public packagekit
(package
(name "packagekit")
@@ -1050,6 +1021,9 @@ functionality not available in the Wayland core protocol. Such protocols either
add completely new functionality, or extend the functionality of some other
protocol either in Wayland core, or some other protocol in wayland-protocols.")
(home-page "https://wayland.freedesktop.org")
+ (properties
+ '((release-monitoring-url
+ . "https://wayland.freedesktop.org/releases.html")))
(license license:expat)))
(define-public waylandpp
@@ -2271,7 +2245,7 @@ fallback to generic Systray support if none of those are available.")
(define-public xdg-desktop-portal
(package
(name "xdg-desktop-portal")
- (version "1.10.1")
+ (version "1.14.4")
(source (origin
(method url-fetch)
(uri (string-append
@@ -2279,7 +2253,7 @@ fallback to generic Systray support if none of those are available.")
version "/xdg-desktop-portal-" version ".tar.xz"))
(sha256
(base32
- "199lqr2plsy9qqnxx5a381ml8ygcbz4nkjla5pvljjcrwzlqsygd"))))
+ "0wqc9x3k7lf3mig53i4rjazi0xi8bcykwaaw7r7prvnscnd1k405"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)
@@ -2290,7 +2264,8 @@ fallback to generic Systray support if none of those are available.")
("which" ,which)
("gettext" ,gettext-minimal)))
(inputs
- `(("glib" ,glib)
+ `(("gdk-pixbuf" ,gdk-pixbuf)
+ ("glib" ,glib)
("flatpak" ,flatpak)
("fontconfig" ,fontconfig)
("json-glib" ,json-glib)
@@ -2298,17 +2273,20 @@ fallback to generic Systray support if none of those are available.")
("dbus" ,dbus)
("geoclue" ,geoclue)
("pipewire" ,pipewire-0.3)
- ("fuse" ,fuse)))
+ ("fuse" ,fuse-3)))
(arguments
- `(#:phases
+ `(#:configure-flags
+ (list "--with-systemd=no")
+ #:phases
(modify-phases %standard-phases
(add-after 'unpack 'po-chmod
(lambda _
;; Make sure 'msgmerge' can modify the PO files.
(for-each (lambda (po)
(chmod po #o666))
- (find-files "po" "\\.po$"))
- #t)))))
+ (find-files "po" "\\.po$"))))
+ (add-after 'unpack 'set-home-directory
+ (lambda _ (setenv "HOME" "/tmp"))))))
(native-search-paths
(list (search-path-specification
(variable "XDG_DESKTOP_PORTAL_DIR")
@@ -2330,7 +2308,7 @@ and others.")
(define-public xdg-desktop-portal-gtk
(package
(name "xdg-desktop-portal-gtk")
- (version "1.10.0")
+ (version "1.14.0")
(source (origin
(method url-fetch)
(uri (string-append
@@ -2338,7 +2316,7 @@ and others.")
version "/xdg-desktop-portal-gtk-" version ".tar.xz"))
(sha256
(base32
- "0nlbnd6qvs92fanrmmn123vy0y2ml0v3ndxyk5x0cpfbnmxpa2f8"))))
+ "0m29b4hm7lq06gcavxw7gdlgqiiy3vgv3v4yjqfq5kx92q3j28gn"))))
(build-system glib-or-gtk-build-system)
(arguments
`(#:phases