summaryrefslogtreecommitdiff
path: root/gnu/packages/freedesktop.scm
diff options
context:
space:
mode:
authorDavid Craven <david@craven.ch>2016-08-15 00:23:48 +0200
committerDavid Craven <david@craven.ch>2016-08-18 13:06:23 +0200
commiteca4c011b5f4e61ee521692b7e27b190f563e816 (patch)
tree3bac1c21d1182febb8562245a9b14fda89df696f /gnu/packages/freedesktop.scm
parente5e1df4dc578aaa633c3f94429a4b19267d51c39 (diff)
gnu: Add wayland-protocols.
* gnu/packages/freedesktop.scm (wayland-protocols): New variable.
Diffstat (limited to 'gnu/packages/freedesktop.scm')
-rw-r--r--gnu/packages/freedesktop.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 0262d0a1ed..67f1e1a2c0 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -295,6 +295,28 @@ application, or a wayland client itself. The clients can be traditional
applications, X servers (rootless or fullscreen) or other display servers.")
(license license:x11)))
+(define-public wayland-protocols
+ (package
+ (name "wayland-protocols")
+ (version "1.4")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://wayland.freedesktop.org/releases/"
+ "wayland-protocols-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0wpm7mz7ww6nn3vrgz7a9iyk7mk6za73wnq0n54lzl8yq8irljh1"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("wayland" ,wayland)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (synopsis "Wayland protocols")
+ (description "This package contains XML definitions of the Wayland protocols.")
+ (home-page "https://wayland.freedesktop.org")
+ (license license:expat)))
+
(define-public exempi
(package
(name "exempi")