summaryrefslogtreecommitdiff
path: root/gnu/packages/game-development.scm
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2015-11-14 14:00:20 -0500
committerDavid Thompson <dthompson2@worcester.edu>2015-11-16 08:47:23 -0500
commit83a4a70b504e158055e384c6a0e267c1270c6beb (patch)
tree9e7261b30bce6b2bf00a910789cba8a9c38187ec /gnu/packages/game-development.scm
parent3aab2c839fe04f503668029204e21358f901e62f (diff)
gnu: Add love.
* gnu/packages/game-development.scm (love): New variable.
Diffstat (limited to 'gnu/packages/game-development.scm')
-rw-r--r--gnu/packages/game-development.scm36
1 files changed, 35 insertions, 1 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index fcebf2b548..1e3854aab1 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -48,7 +48,9 @@
#:use-module (gnu packages gtk)
#:use-module (gnu packages sdl)
#:use-module (gnu packages pkg-config)
- #:use-module (gnu packages xiph))
+ #:use-module (gnu packages xiph)
+ #:use-module (gnu packages lua)
+ #:use-module (gnu packages mp3))
(define-public bullet
(package
@@ -260,3 +262,35 @@ files can be accessed in the same way as you access files directly on a disk,
and it makes it easy to ship a new archive that will override a previous
archive on a per-file basis.")
(license license:zlib)))
+
+(define-public love
+ (package
+ (name "love")
+ (version "0.9.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://bitbucket.org/rude/love/downloads/"
+ "love-" version "-linux-src.tar.gz"))
+ (sha256
+ (base32
+ "0wn1npr5gal5b1idh4a5fwc3f5c36lsbjd4r4d699rqlviid15d9"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("devil" ,devil)
+ ("freetype" ,freetype)
+ ("libmodplug" ,libmodplug)
+ ("libvorbis" ,libvorbis)
+ ("luajit" ,luajit)
+ ("mesa" ,mesa)
+ ("mpg123" ,mpg123)
+ ("openal" ,openal)
+ ("physfs" ,physfs)
+ ("sdl2" ,sdl2)
+ ("zlib" ,zlib)))
+ (synopsis "2D game framework for Lua")
+ (description "LÖVE is a framework for making 2D games in the Lua
+programming language.")
+ (home-page "https://love2d.org/")
+ (license license:zlib)))