summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
author宋文武 <iyzsong@member.fsf.org>2023-08-20 19:21:30 +0800
committer宋文武 <iyzsong@member.fsf.org>2023-08-23 18:49:23 +0800
commit12a25f1858a8b8987eda5fa1041c368e232c4163 (patch)
tree2c51587ace4f305f133fccde66d80a8a2cb400ac /gnu/packages/games.scm
parent9393ce89ab967823ef693915ed30d4d04a8fc818 (diff)
gnu: tetrinet: Fix build.
* gnu/packages/games.scm (tetrinet)[arguments]: Add '-fcommon' to CFLAGS.
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 7cc9205959..34558eb712 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -713,7 +713,8 @@ canyons and wait for the long I-shaped block to clear four rows at a time.")
(list ncurses))
(arguments
`(#:tests? #f ;no tests
- #:make-flags '("CC=gcc")
+ #:make-flags '("CC=gcc"
+ "CFLAGS=-O2 -DHAVE_IPV6 -g -Wall -fcommon")
#:phases
(modify-phases %standard-phases
(delete 'configure) ;no configure script