summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-10-23 22:53:12 +0200
committerLudovic Courtès <ludo@gnu.org>2021-10-23 23:05:21 +0200
commit2dffe4767c64e00a2b97b71b9e2ac568ffc99595 (patch)
treef103a9611d8c02ea63d88f8f7b3c92ff8fd30201 /gnu/packages/games.scm
parente5f21c7e38fc7c61271e532f434284c94cd6fbb3 (diff)
gnu: Use 'search-input-file' some more.
This patch replaces occurrences of: (string-append (assoc-ref %build-inputs "…") "/…") by: (search-input-file %build-inputs "/…") * doc/guix.texi (Miscellaneous Services): Use 'search-input-file' in R Shiny example. * gnu/packages/admin.scm (screenfetch): Use 'search-input-file'. (ufetch): Likewise. (hosts): Likewise. * gnu/packages/backup.scm (dirvish): Likewise. * gnu/packages/code.scm (colormake): Likewise. * gnu/packages/compression.scm (makeself-safeextract): Likewise. * gnu/packages/debug.scm (scanmem): Likewise. * gnu/packages/education.scm (snap): Likewise. (omnitux): Likewise. * gnu/packages/emacs-xyz.scm (epipe): Likewise. * gnu/packages/games.scm (openttd-opensfx): Likewise. (openttd-openmsx): Likewise. (openrct2-title-sequences): Likewise. (openrct2-objects): Likewise. (mrrescue): Likewise. (0ad-data): Likewise. (xonotic-data): Likewise. (drascula): Likewise. (make-lure-package): Likewise. (make-queen-package): Likewise. (sky): Likewise. * gnu/packages/gnome.scm (network-manager): Likewise. * gnu/packages/gnuzilla.scm (icedove): Likewise. * gnu/packages/guile-xyz.scm (guile-shapefile): Likewise. * gnu/packages/hurd.scm (netdde): Likewise. * gnu/packages/javascript.scm (js-context-menu): Likewise. (js-commander): Likewise. (js-xmldom-sre): Likewise. * gnu/packages/kde-frameworks.scm (krunner): Likewise. * gnu/packages/kodi.scm (kodi-cli): Likewise. * gnu/packages/libreoffice.scm (hunspell-dict-pl): Likewise. * gnu/packages/linux.scm (e2fsck/static): Likewise. * gnu/packages/markup.scm (markdown): Likewise. * gnu/packages/maths.scm (hdf-java): Likewise. * gnu/packages/multiprecision.scm (libtomcrypt): Likewise. * gnu/packages/networking.scm (batctl): Likewise. * gnu/packages/python-xyz.scm (python-pymediainfo): Likewise. * gnu/packages/shells.scm (fish-foreign-env): Likewise. * gnu/packages/tex.scm (texlive-fonts-iwona): Likewise. * gnu/packages/upnp.scm (miniupnpc): Likewise. * gnu/packages/version-control.scm (git-annex-remote-rclone): Likewise. * gnu/packages/virtualization.scm (qemu): Likewise. * gnu/packages/web.scm (icedtea-web): Likewise. * gnu/packages/wm.scm (stumpish): Likewise.
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm43
1 files changed, 17 insertions, 26 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 3909a6c5a9..c913d99334 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -4390,8 +4390,8 @@ OpenGFX provides you with...
(arguments
`(#:make-flags
(list (string-append "DIR_NAME=opensfx")
- (string-append "TAR=" (assoc-ref %build-inputs "tar")
- "/bin/tar"))
+ (string-append "TAR="
+ (search-input-file %build-inputs "/bin/tar")))
;; The check phase only verifies md5sums, see openttd-opengfx.
#:tests? #f
#:phases
@@ -4440,8 +4440,8 @@ the original Transport Tycoon Deluxe.")
(arguments
`(#:make-flags
(list (string-append "DIR_NAME=openmsx")
- (string-append "TAR=" (assoc-ref %build-inputs "tar")
- "/bin/tar"))
+ (string-append "TAR="
+ (search-input-file %build-inputs "/bin/tar")))
;; The check phase only verifies md5sums, see openttd-opengfx.
#:tests? #f
#:phases
@@ -4513,7 +4513,7 @@ Transport Tycoon Deluxe.")
(openrct2-title-sequences (string-append out
"/share/openrct2/title-sequences"))
(source (assoc-ref %build-inputs "source"))
- (unzip (string-append (assoc-ref %build-inputs "unzip") "/bin/unzip")))
+ (unzip (search-input-file %build-inputs "/bin/unzip")))
(copy-file source (string-append ,name "-" ,version ".zip"))
(invoke unzip (string-append ,name "-" ,version ".zip"))
(delete-file (string-append ,name "-" ,version ".zip"))
@@ -4553,7 +4553,7 @@ Transport Tycoon Deluxe.")
(openrct2-objects (string-append out
"/share/openrct2/objects"))
(source (assoc-ref %build-inputs "source"))
- (unzip (string-append (assoc-ref %build-inputs "unzip") "/bin/unzip")))
+ (unzip (search-input-file %build-inputs "/bin/unzip")))
(copy-file source (string-append ,name "-" ,version ".zip"))
(invoke unzip (string-append ,name "-" ,version ".zip"))
(delete-file (string-append ,name "-" ,version ".zip"))
@@ -5714,14 +5714,10 @@ colors, pictures, and sounds.")
(script (string-append out "/bin/" ,name))
(data (string-append out "/share/" ,name))
(source (assoc-ref %build-inputs "source"))
- (unzip (string-append (assoc-ref %build-inputs "unzip")
- "/bin/unzip"))
- (patch (string-append (assoc-ref %build-inputs "patch")
- "/bin/patch"))
- (bash (string-append (assoc-ref %build-inputs "bash")
- "/bin/bash"))
- (love (string-append (assoc-ref %build-inputs "love")
- "/bin/love")))
+ (unzip (search-input-file %build-inputs "/bin/unzip"))
+ (patch (search-input-file %build-inputs "/bin/patch"))
+ (bash (search-input-file %build-inputs "/bin/bash"))
+ (love (search-input-file %build-inputs "/bin/love")))
(mkdir-p (dirname script))
(with-output-to-file script
@@ -6683,7 +6679,7 @@ fight against their plot and save his fellow rabbits from slavery.")
(use-modules (guix build utils))
(let ((out (assoc-ref %outputs "out"))
(source (assoc-ref %build-inputs "source"))
- (tar (string-append (assoc-ref %build-inputs "tar") "/bin/tar"))
+ (tar (search-input-file %build-inputs "/bin/tar"))
(xz-path (string-append (assoc-ref %build-inputs "xz") "/bin")))
(setenv "PATH" xz-path)
(mkdir out)
@@ -7758,7 +7754,7 @@ quotation from a collection of quotes.")
(let* ((out (assoc-ref %outputs "out"))
(xonotic (string-append out "/share/xonotic"))
(source (assoc-ref %build-inputs "source"))
- (unzip (string-append (assoc-ref %build-inputs "unzip") "/bin/unzip")))
+ (unzip (search-input-file %build-inputs "/bin/unzip")))
(copy-file source (string-append ,name "-" ,version ".zip"))
(invoke unzip (string-append ,name "-" ,version ".zip"))
(mkdir-p out)
@@ -9547,8 +9543,7 @@ on items and player adaptability for character progression.")
(share (string-append out "/share/drascula"))
(scummvm (assoc-ref %build-inputs "scummvm")))
;; Install data.
- (let ((unzip (string-append (assoc-ref %build-inputs "unzip")
- "/bin/unzip"))
+ (let ((unzip (search-input-file %build-inputs "/bin/unzip"))
(doc (string-append out "/share/doc/" ,name "-" ,version)))
(for-each
(lambda (input)
@@ -9574,8 +9569,7 @@ on items and player adaptability for character progression.")
;; Create standalone executable.
(let* ((bin (string-append out "/bin"))
(executable (string-append bin "/drascula"))
- (bash (string-append (assoc-ref %build-inputs "bash")
- "/bin/bash")))
+ (bash (search-input-file %build-inputs "/bin/bash")))
(mkdir-p bin)
(with-output-to-file executable
(lambda ()
@@ -9665,8 +9659,7 @@ the World and demonstrating that he is even more evil than his brother Vlad.")
(bin (string-append out "/bin"))
(executable (string-append bin "/" ,name))
(scummvm (assoc-ref %build-inputs "scummvm")))
- (let ((unzip (string-append (assoc-ref %build-inputs "unzip")
- "/bin/unzip")))
+ (let ((unzip (search-input-file %build-inputs "/bin/unzip")))
(invoke unzip "-j" (assoc-ref %build-inputs "source")))
(let ((doc (string-append share "/doc/" ,name "-" ,version)))
(for-each (lambda (f) (install-file f doc))
@@ -9772,8 +9765,7 @@ Skorl. Maybe it would be an idea to try and escape...")
(bin (string-append out "/bin"))
(executable (string-append bin "/" ,name))
(scummvm (assoc-ref %build-inputs "scummvm")))
- (let ((unzip (string-append (assoc-ref %build-inputs "unzip")
- "/bin/unzip")))
+ (let ((unzip (search-input-file %build-inputs "/bin/unzip")))
(invoke unzip "-j" (assoc-ref %build-inputs "source")))
(let ((doc (string-append share "/doc/" ,name "-" ,version)))
(install-file "readme.txt" doc))
@@ -9871,8 +9863,7 @@ women and 6-foot-tall pygmies.")
(bin (string-append out "/bin"))
(executable (string-append bin "/" ,name))
(scummvm (assoc-ref %build-inputs "scummvm")))
- (let ((unzip (string-append (assoc-ref %build-inputs "unzip")
- "/bin/unzip")))
+ (let ((unzip (search-input-file %build-inputs "/bin/unzip")))
(invoke unzip "-j" (assoc-ref %build-inputs "source")))
(let ((doc (string-append share "/doc/bass-" ,version)))
(install-file "readme.txt" doc))