summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-12-30 10:11:26 +0200
committerEfraim Flashner <efraim@flashner.co.il>2020-12-30 10:41:07 +0200
commit50793bd41af7c1fa787bf1b409dcddbbb5224387 (patch)
treee4bd0c580cb448f39838f0ad76b5592fcd91b8dc /gnu/packages/games.scm
parente87a2dea55a65baff45df5a153f46f5f1e1f9e32 (diff)
gnu: kajongg: Wrap binary with pythonpath.
* gnu/packages/games.scm (kajongg)[arguments]: Add phase to wrap binary with PYTHONPATH. [propagated-inputs]: Move python-twisted, python-pyqt ... [inputs]: ... to here.
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm15
1 files changed, 11 insertions, 4 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 54ec564768..c94a1e2d54 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -10119,6 +10119,15 @@ This package is part of the KDE games module.")
(sha256
(base32 "0ql6p5zifdpdf65r7ki9ml123azpwwk9x3x8r9ij6xhjnf7p7x6w"))))
(build-system qt-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'wrap
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (wrap-program (string-append out "/bin/kajongg")
+ `("PYTHONPATH" ":" prefix (,(getenv "PYTHONPATH"))))
+ #t))))))
(native-inputs
`(("extra-cmake-modules" ,extra-cmake-modules)
;("perl" ,perl)
@@ -10130,12 +10139,10 @@ This package is part of the KDE games module.")
("ki18n" ,ki18n)
("libkmahjongg" ,libkmahjongg)
("python" ,python)
+ ("python-twisted" ,python-twisted)
+ ("python-pyqt" ,python-pyqt)
("qtbase" ,qtbase)
("qtsvg" ,qtsvg)))
- (propagated-inputs
- `(("python-twisted" ,python-twisted)
- ("python-pyqt" ,python-pyqt)))
- ;; FIXME: Need to wrap PYTHONPATH
(home-page "https://games.kde.org/")
(synopsis "Classical Mah Jongg game for 4 players")
(description "Kajongg is the ancient Chinese board game for 4 players.