summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorFelix Gruber <felgru@posteo.net>2021-09-11 19:50:20 +0000
committerGuillaume Le Vaillant <glv@posteo.net>2021-09-12 09:40:57 +0200
commit58d3c8bb1ee42bcca05ba05187748c9e130cab67 (patch)
treeb1c9fda277f0ad787e961f560993e548f4e92e59 /gnu/packages/games.scm
parent99a7bc993d022b3bc74a2ed57f53bf19d69c5137 (diff)
gnu: chocolate-doom: Fix compilation with GCC 10.
* gnu/packages/games.scm (chocolate-doom)[arguments]: Pass '-fcommon' to CFLAGS. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm2
1 files changed, 2 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index e60987d834..410dccafdc 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -7467,6 +7467,8 @@ online.")
(base32
"1iy8rx7kjvi1zjiw4zh77szzmd1sgpqajvbhprh1sj93fhbxcdfl"))))
(build-system gnu-build-system)
+ (arguments
+ `(#:configure-flags (list "CFLAGS=-fcommon")))
(inputs `(("sdl2-net" ,sdl2-net)
("sdl2-mixer" , sdl2-mixer)
("sdl2" ,sdl2)))