summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2021-11-20 04:02:54 +0100
committerJulien Lepiller <julien@lepiller.eu>2021-11-20 04:02:54 +0100
commit70a88dac11d3cb47c1058ed65d3970fe27517c77 (patch)
treecde9a0368bf34670689efa03b9ed4750d116fa52 /gnu/packages/games.scm
parent42eeea188d03e5c9943d653ec0afa6ff0ae2a9ad (diff)
gnu: laby: Fix build.
* gnu/packages/games.scm (laby)[inputs]: Use lablgtk3. [arguments]: Remove allow-unsafe-strings phase.
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm10
1 files changed, 2 insertions, 8 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 395b108ef4..3b40a8babd 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -5642,7 +5642,7 @@ Linux / Mac OS X servers, and an auto mapper with a VT100 map display.")
(patches (search-patches "laby-make-install.patch"))))
(build-system gnu-build-system)
(inputs
- `(("lablgtk" ,lablgtk)
+ `(("lablgtk3" ,lablgtk3)
("ocaml" ,ocaml)
("ocaml-findlib" ,ocaml-findlib)
("ocamlbuild" ,ocamlbuild)))
@@ -5650,15 +5650,9 @@ Linux / Mac OS X servers, and an auto mapper with a VT100 map display.")
'(#:phases
(modify-phases %standard-phases
(delete 'configure)
- (add-before 'build 'allow-unsafe-strings
- ;; Fix a build failure with ocaml >=4.06.0.
- ;; See <https://github.com/sgimenez/laby/issues/53>.
- (lambda _
- (setenv "OCAMLPARAM" "safe-string=0,_")
- #t))
(add-before 'build 'set-library-path
(lambda* (#:key inputs #:allow-other-keys)
- (let ((lablgtk (assoc-ref inputs "lablgtk")))
+ (let ((lablgtk (assoc-ref inputs "lablgtk3")))
(setenv "LD_LIBRARY_PATH"
(string-append lablgtk "/lib/ocaml/stublibs"))))))
#:tests? #f ; no 'check' target