summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorphodina via Guix-patches via <guix-patches@gnu.org>2021-09-27 22:24:38 +0000
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-09-28 21:39:48 +0200
commit87178ed29ef519d8680062beacc3b9b178c10134 (patch)
tree26681cdc47c95fc1b91d4a7c8398ff8069e24355 /gnu/packages/games.scm
parentf9ed753c7b3349e7c2160a4ae4bae9e5b11bd34e (diff)
gnu: Add falltergeist.
* gnu/packages/games.scm (falltergeist): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index e564ddff6a..dabbbe6ea1 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -1134,6 +1134,34 @@ regular @command{cat}, but it also adds terminal escape codes between
characters and lines resulting in a rainbow effect.")
(license license:wtfpl2))))
+(define-public falltergeist
+ (package
+ (name "falltergeist")
+ (version "0.3.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/falltergeist/falltergeist")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "05cg58i2g32wbmrvmdsicic8xs83gld3qr1p7r4lnlckcl1l7dy4"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f)) ; no tests provided
+ (native-inputs `(("pkg-config" ,pkg-config)))
+ (inputs `(("sdl" ,(sdl-union (list sdl2
+ sdl2-image
+ sdl2-mixer)))
+ ("glew" ,glew)
+ ("glm" ,glm)))
+ (home-page "https://falltergeist.org/")
+ (synopsis "Fallout 2 game engine")
+ (description "This package provides the Fallout 2 game engine. Game data
+should be placed in @file{~/.local/share/falltergeist}.")
+ (license license:gpl3+)))
+
(define-public foobillard++
;; Even though this latest revision is old already, stable release is
;; lagging way behind it, and has issues with textures rendering.