summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-11-03 22:10:34 +0200
committerEfraim Flashner <efraim@flashner.co.il>2021-11-04 00:11:08 +0200
commitaae82f2a9587bf5c9f0af21be26e38e3bd941a84 (patch)
treeb0373eaef599c630e0f81cfb9a0eece1877fd251 /gnu/packages/games.scm
parent230b34cb5c88bcfda155094fde85a0a125f490f2 (diff)
gnu: flightgear: Build with newer inputs.
* gnu/packages/games.scm (flightgear)[inputs]: Replace openscenegraph-3.4 with openscenegraph, boost-for-mysql with boost. (simgear)[inputs]: Same.
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index b1de90cf24..1ea1846c0a 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -9280,12 +9280,12 @@ levels to unlock.")
;; Skip tests that require internet access.
(invoke "ctest" "-E" "(http|dns)")))))))
(inputs
- `(("boost" ,boost-for-mysql) ; fails with 1.69
+ `(("boost" ,boost)
("curl" ,curl)
("expat" ,expat)
("mesa" ,mesa)
("openal" ,openal)
- ("openscenegraph" ,openscenegraph-3.4)
+ ("openscenegraph" ,openscenegraph)
("zlib" ,zlib)))
(home-page "https://home.flightgear.org/")
(synopsis "Libraries for 3D simulations and games")
@@ -9335,7 +9335,7 @@ and also provides the base for the FlightGear Flight Simulator.")
"--strip-components=1")))
#t)))))
(inputs
- `(("boost" ,boost-for-mysql) ; same as simgear
+ `(("boost" ,boost)
("dbus" ,dbus)
("eudev" ,eudev)
("freeglut" ,freeglut)
@@ -9343,7 +9343,7 @@ and also provides the base for the FlightGear Flight Simulator.")
("glew" ,glew)
("libpng" ,libpng)
("openal" ,openal)
- ("openscenegraph" ,openscenegraph-3.4)
+ ("openscenegraph" ,openscenegraph)
("plib" ,plib)
("qtbase" ,qtbase-5)
("qtdeclarative" ,qtdeclarative)