summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorSolene Rapenne via Guix-patches via <guix-patches@gnu.org>2021-05-24 10:34:14 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-05-25 12:07:32 +0200
commitb1bbeeafb42381ff30f3ec75cd02fba8d4f519a9 (patch)
tree55d2534626d9666643a7e2b67fccff9c0230e377 /gnu/packages/games.scm
parentf820315ddd92c4c8516b0ee168993b95de076c11 (diff)
gnu: openttd-engine: Update to 1.11.2.
* gnu/packages/games.scm (openttd-engine): Update to 1.11.2. [build-system]: Switch to CMake. [arguments]: Enable tests. (openttd)[arguments]<#:configure-flags>: Use CMake flags. <#:phases>: Remove `configure'. Copy assets file before check step to enable tests. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm51
1 files changed, 15 insertions, 36 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 6f07cd3aa9..c7e6097bd4 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -61,6 +61,7 @@
;;; Copyright © 2021 Greg Hogan <code@greghogan.com>
;;; Copyright © 2021 David Pflug <david@pflug.io>
;;; Copyright © 2021 Felix Gruber <felgru@posteo.net>
+;;; Copyright © 2021 Solene Rapenne <solene@perso.pw>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -4315,35 +4316,15 @@ world}, @uref{http://evolonline.org, Evol Online} and
(define openttd-engine
(package
(name "openttd-engine")
- (version "1.10.3")
+ (version "1.11.2")
(source
(origin (method url-fetch)
(uri (string-append "https://cdn.openttd.org/openttd-releases/"
version "/openttd-" version "-source.tar.xz"))
(sha256
(base32
- "0fxmfz1mm95a2x0rnzfff9wb8q57w0cvsdd0z7agdcbyakph25n1"))))
- (build-system gnu-build-system)
- (arguments
- `(#:tests? #f ; no "check" target
- #:phases
- (modify-phases %standard-phases
- ;; The build process fails if the configure script is passed the
- ;; option "--enable-fast-install".
- (replace 'configure
- (lambda* (#:key inputs outputs (configure-flags '())
- #:allow-other-keys)
- (let ((out (assoc-ref outputs "out"))
- (lzo (assoc-ref inputs "lzo")))
- (apply invoke "./configure"
- (string-append "--prefix=" out)
- ;; Provide the "lzo" path.
- (string-append "--with-liblzo2="
- lzo "/lib/liblzo2.a")
- ;; Put the binary in 'bin' instead of 'games'.
- "--binary-dir=bin"
- configure-flags)))))))
- (native-inputs `(("pkg-config" ,pkg-config)))
+ "0v9f93lsdcv3ia28y8iihx9nj9zp6fpf5hkdrpl4ypw159d97fhg"))))
+ (build-system cmake-build-system)
(inputs
`(("allegro" ,allegro)
("fontconfig" ,fontconfig)
@@ -4510,19 +4491,17 @@ Transport Tycoon Deluxe.")
(name "openttd")
(arguments
`(#:configure-flags
- (list (string-append "--with-midi=" (assoc-ref %build-inputs "timidity++")
- "/bin/timidity"))
- ,@(substitute-keyword-arguments (package-arguments openttd-engine)
- ((#:phases phases)
- `(modify-phases ,phases
- (add-after 'install 'install-data
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (for-each
- (lambda (input)
- (copy-recursively (assoc-ref inputs input)
- (assoc-ref outputs "out")))
- (list "opengfx" "openmsx" "opensfx"))
- #t)))))))
+ (let* ((out (assoc-ref %outputs "out")))
+ (list (string-append "-DCMAKE_INSTALL_BINDIR=" out "/bin")))
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'install-data
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (for-each
+ (lambda (input)
+ (copy-recursively (assoc-ref inputs input)
+ (assoc-ref outputs "out")))
+ (list "opengfx" "openmsx" "opensfx")))))))
(inputs
`(("timidity++" ,timidity++)
,@(package-inputs openttd-engine)))