summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-11-03 22:39:47 +0200
committerEfraim Flashner <efraim@flashner.co.il>2021-11-04 00:11:09 +0200
commitb93e06a96418b7caba109cae327c3d226a33d782 (patch)
tree0b1efcd118c538d048a6075d2e8005c836f97f1c /gnu/packages/games.scm
parentd3abd5cd8b16a9a4121da08a2778dd8a3b9cbae6 (diff)
gnu: flightgear: Use system cppunit.
* gnu/packages/games.scm (flightgear)[source]: Adjust snippet to remove bundled cppunit. [arguments]: Add configure-flag to use system cppunit.
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index df32a6b27d..7bab31f9be 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -9320,12 +9320,14 @@ and also provides the base for the FlightGear Flight Simulator.")
'(begin
;; There are some bundled libraries.
(for-each delete-file-recursively
- '("3rdparty/sqlite3/"))
+ '("3rdparty/sqlite3/"
+ "3rdparty/cppunit/"))
#t))))
(build-system qt-build-system)
(arguments
`(#:configure-flags
(list "-DSYSTEM_SQLITE=ON"
+ "-DSYSTEM_CPPUNIT=ON"
(string-append "-DFG_DATA_DIR="
(assoc-ref %outputs "out")
"/share/flightgear"))