summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
author宋文武 <iyzsong@member.fsf.org>2024-06-03 12:09:49 +0800
committerChristopher Baines <mail@cbaines.net>2024-06-11 11:46:16 +0100
commitcca59ba0e330d3ed95ae4398510bbf6b8241f54c (patch)
treebbbe3438a553cadc009ebb4c062fb3fa92217ce8 /gnu/packages/games.scm
parentf57a0523c405650725eea942bc9ef29995b3f855 (diff)
gnu: opensurge: Update to 0.6.1.1.
* gnu/packages/games.scm (opensurge): Update to 0.6.1.1. [inputs]: Add mesa and physfs. Change-Id: Ia62559372757f7cfd6dc4784e2a8271bbe6d7868 Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index e24494b8a1..59b169171c 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -1850,7 +1850,7 @@ shadow mimic them to reach blocks you couldn't reach alone.")
(define-public opensurge
(package
(name "opensurge")
- (version "0.6.0.3")
+ (version "0.6.1.1")
(source
(origin
(method git-fetch)
@@ -1859,7 +1859,7 @@ shadow mimic them to reach blocks you couldn't reach alone.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0yia2qcva741a64qpls8a59lvnx5vynqkk2i3arkflw6f1m1vb55"))))
+ (base32 "1hwnjgkbywspmsmpmmnndqil86qqyd21y2q5krs8znwi35ychd3q"))))
(build-system cmake-build-system)
(arguments
(list #:tests? #f ; there are no tests
@@ -1891,7 +1891,7 @@ shadow mimic them to reach blocks you couldn't reach alone.")
"Roboto-Bold.ttf"
"Roboto-Medium.ttf"))))))))
(inputs
- (list allegro font-google-roboto surgescript xdg-utils))
+ (list allegro font-google-roboto mesa physfs surgescript xdg-utils))
(home-page "https://opensurge2d.org")
(synopsis "2D retro side-scrolling game")
(description "@code{Open Surge} is a 2D retro side-scrolling platformer