summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-10-15 21:57:22 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-10-16 17:30:29 +0200
commitdfbc2236ee669317cf021d06d7c079b91fe48b91 (patch)
treefaa5961b257c0de3d56fe0867b703b6197364087 /gnu/packages/games.scm
parente2c4d8d6da50098d8be18da90e28d5ed3d4814ce (diff)
gnu: angband: Update to 4.2.3.
* gnu/packages/games.scm (angband): Update to 4.2.3. [source]: Use GIT-FETCH and GIT-FILE-NAME. [arguments]: Remove custom 'bootstrap phase.
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm22
1 files changed, 8 insertions, 14 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 48cda7da07..38852a2874 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -3067,15 +3067,16 @@ that beneath its ruins lay buried an ancient evil.")
(define-public angband
(package
(name "angband")
- (version "4.2.1")
+ (version "4.2.3")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://rephial.org/downloads/"
- (version-major+minor version)
- "/angband-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/angband/angband")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
- (base32 "03qdavkj2ik02mqjxmlm5bn17ba3yxb1rirp8ghnxy3bsk4kbmxc"))
+ (base32 "1psrdbf90mb6dhq0b9z18pz1csnshz1kvwg82dvwa99apqdw0la8"))
(modules '((guix build utils)))
(snippet
;; So, some of the sounds/graphics/tilesets are under different
@@ -3096,14 +3097,7 @@ that beneath its ruins lay buried an ancient evil.")
(build-system gnu-build-system)
(arguments
`(#:tests? #f ; no check target
- #:configure-flags (list (string-append "--bindir=" %output "/bin"))
- #:phases
- (modify-phases %standard-phases
- (replace 'bootstrap
- (lambda _
- (substitute* "acinclude.m4"
- (("ncursesw5-config") "ncursesw6-config"))
- (invoke "sh" "autogen.sh"))))))
+ #:configure-flags (list (string-append "--bindir=" %output "/bin"))))
(native-inputs
`(("autoconf" ,autoconf)
("automake" ,automake)))