summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorGuix Together <jgart@dismail.de>2021-08-30 12:40:40 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-08-30 15:16:09 -0400
commitf48156dc9d52bdef97c3ec6c3462ccdd66f4d6e7 (patch)
treeef87936dfb1476245f0f819bf414e23f4f3df9fe /gnu/packages/games.scm
parentcc71a54e9f900e905192f794c7bc5346c445e651 (diff)
gnu: Add go-github-com-anaseto-gruid.
* gnu/packages/games.scm (go-github-com-anaseto-gruid): New variable. Co-authored-by: Arun Isaac <arunisaac@systemreboot.net> Co-authored-by: Brice Waegeneire <brice@waegenei.re> Co-authored-by: jgart <jgart@dismail.de> Co-authored-by: Julien Lepiller <julien@lepiller.eu> Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 07a61f2c0b..8c299c8b89 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -131,6 +131,7 @@
#:use-module (gnu packages gnu-doc)
#:use-module (gnu packages gnupg)
#:use-module (gnu packages gnuzilla)
+ #:use-module (gnu packages golang)
#:use-module (gnu packages gperf)
#:use-module (gnu packages graphics)
#:use-module (gnu packages gsasl)
@@ -9373,6 +9374,35 @@ and bring the war to your enemy.")
license:expat license:fdl1.3+ license:public-domain
license:zlib))))
+(define-public go-github-com-anaseto-gruid
+ (package
+ (name "go-github-com-anaseto-gruid")
+ (version "0.21.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/anaseto/gruid")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0rvsavkvg2hziwdh8sjk3n5v92m5mfjb8v9m7ch22maxfwq5kv6y"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/anaseto/gruid"))
+ (propagated-inputs
+ `(("go-golang-org-x-image" ,go-golang-org-x-image)))
+ (home-page "https://github.com/anaseto/gruid")
+ (synopsis "Cross-platform grid-based UI and game framework")
+ (description "The gruid module provides packages for easily building
+grid-based applications in Go. The library abstracts rendering and input for
+different platforms. There are drivers available for terminal apps, native
+graphical apps and browser apps. The original application for the library was
+creating grid-based games, but it's also well suited for any grid-based
+application.")
+ (license license:isc)))
+
(define-public harmonist
(package
(name "harmonist")