summaryrefslogtreecommitdiff
path: root/gnu/packages/gcc.scm
diff options
context:
space:
mode:
authorfanquake <fanquake@gmail.com>2023-08-10 12:05:32 +0200
committerLudovic Courtès <ludo@gnu.org>2023-10-24 00:02:13 +0200
commit2fbb5398a39bf18e41235891a0740fa0bc4d7a4d (patch)
treeb3551ec36d5f62acba13d2998c50ff055f4e855a /gnu/packages/gcc.scm
parentcbd20d627497053871db863970c07d93c7081786 (diff)
gnu: gcc@10: Update to 10.5.0.
* gnu/packages/gcc.scm (gcc-10): Update to 10.5.0. Remove ‘gcc-10-tree-sra-union-handling.patch’. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Change-Id: Id1121cde63c8f5572fbe6a2b0d18b2df5a1eaa68
Diffstat (limited to 'gnu/packages/gcc.scm')
-rw-r--r--gnu/packages/gcc.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index 04926e6385..621644b93f 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -706,17 +706,16 @@ It also includes runtime support libraries for these languages.")
(define-public gcc-10
(package
(inherit gcc-8)
- (version "10.4.0")
+ (version "10.5.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/gcc/gcc-"
version "/gcc-" version ".tar.xz"))
(sha256
(base32
- "1wg4xdizkksmwi66mvv2v4pk3ja8x64m7v9gzhykzd3wrmdpsaf9"))
+ "1h87lcfaga0ydsf4pkhwlnjr8mky5ix8npbv6iy3jvzlzm1ra415"))
(patches (search-patches "gcc-9-strmov-store-file-names.patch"
- "gcc-5.0-libvtv-runpath.patch"
- "gcc-10-tree-sra-union-handling.patch"))
+ "gcc-5.0-libvtv-runpath.patch"))
(modules '((guix build utils)))
(snippet gcc-canadian-cross-objdump-snippet)))
(properties