summaryrefslogtreecommitdiff
path: root/gnu/packages/gcc.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-10-28 22:03:35 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-10-28 22:03:35 +0300
commit4dfbc536689b07e56aead3dd864b8af54613d091 (patch)
tree6ce674e08fc38b4dca397efa0184f94767be7c1b /gnu/packages/gcc.scm
parent84fbfa82af73ee156441935fbc1fa27e017cda90 (diff)
gnu: custom-gcc: Set upstream name.
* gnu/packages/gcc.scm (custom-gcc)[properties]: Add upstream name. Change-Id: I30326dc7952b11451a86f7f026aa1a97364a89e4
Diffstat (limited to 'gnu/packages/gcc.scm')
-rw-r--r--gnu/packages/gcc.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index 4de12e2714..e352cff5f9 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -1058,7 +1058,6 @@ as the 'native-search-paths' field."
(package-outputs gcc)
(delete "lib" (package-outputs gcc))))
(native-search-paths search-paths)
- (properties (alist-delete 'hidden? (package-properties gcc)))
(arguments
(substitute-keyword-arguments (package-arguments gcc)
((#:modules modules %gnu-build-system-modules)
@@ -1078,7 +1077,9 @@ as the 'native-search-paths' field."
(for-each
delete-file
(find-files (string-append (assoc-ref outputs "out") "/bin")
- ".*(c\\+\\+|cpp|g\\+\\+|gcov|gcc|lto)(-.*)?$"))))))))))
+ ".*(c\\+\\+|cpp|g\\+\\+|gcov|gcc|lto)(-.*)?$"))))))))
+ (properties `((upstream-name . "gcc")
+ ,@(alist-delete 'hidden? (package-properties gcc))))))
(define %generic-search-paths
;; This is the language-neutral search path for GCC. Entries in $CPATH are