summaryrefslogtreecommitdiff
path: root/gnu/packages/gcc.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-06-14 23:28:28 +0200
committerLudovic Courtès <ludo@gnu.org>2014-06-14 23:28:28 +0200
commit5c860cec8329cbcf68504791c01b6ebd0571e783 (patch)
treeb0a1ca34c4d11dc3a9cefe1d8449761772a7cf04 /gnu/packages/gcc.scm
parent7470df5ddfa092872836b7e746ba8af50998b6aa (diff)
gnu: gcc: Really avoid 'install-strip' when cross-compiling.
This is a followup to 6b9229c. * gnu/packages/gcc.scm (gcc-4.7): Turn 'install-target' into a thunk, so (%current-target-system) is current.
Diffstat (limited to 'gnu/packages/gcc.scm')
-rw-r--r--gnu/packages/gcc.scm15
1 files changed, 8 insertions, 7 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index 93dc6c0565..c927e6e49c 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -52,12 +52,13 @@ where the OS part is overloaded to denote a specific ABI---into GCC
(define-public gcc-4.7
(let* ((stripped? #t) ; TODO: make this a parameter
(install-target
- ;; The 'install-strip' rule uses the native 'strip' instead of
- ;; 'TARGET-strip' when cross-compiling. Thus, use 'install' in that
- ;; case.
- (if (and stripped? (not (%current-target-system)))
- "install-strip"
- "install"))
+ (lambda ()
+ ;; The 'install-strip' rule uses the native 'strip' instead of
+ ;; 'TARGET-strip' when cross-compiling. Thus, use 'install' in that
+ ;; case.
+ (if (and stripped? (not (%current-target-system)))
+ "install-strip"
+ "install")))
(maybe-target-tools
(lambda ()
;; Return the `_FOR_TARGET' variables that are needed when
@@ -238,7 +239,7 @@ where the OS part is overloaded to denote a specific ABI---into GCC
(alist-replace 'install
(lambda* (#:key outputs #:allow-other-keys)
(zero?
- (system* "make" ,install-target)))
+ (system* "make" ,(install-target))))
%standard-phases)))))
(native-search-paths