summaryrefslogtreecommitdiff
path: root/gnu/packages/gcc.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2023-04-14 11:43:38 +0200
committerAndreas Enge <andreas@enge.fr>2023-04-14 11:43:38 +0200
commit66b5d33c4ff8d146fa7f0e6e642008ac7e8cfb9d (patch)
treef784fee6eeff3c12906c896d0ad0919d51ea9ff3 /gnu/packages/gcc.scm
parent9900f9e9b86550e7d336b04ad46fba088e28cbd6 (diff)
Revert "gnu: gcc-11: Fix build on powerpc64le."
This reverts commit 9900f9e9b86550e7d336b04ad46fba088e28cbd6.
Diffstat (limited to 'gnu/packages/gcc.scm')
-rw-r--r--gnu/packages/gcc.scm11
1 files changed, 1 insertions, 10 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index ae324219d3..a511cdbc45 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -2,7 +2,7 @@
;;; Copyright © 2012-2023 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014, 2015, 2018 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2014, 2015, 2016, 2017, 2019, 2021 Ricardo Wurmus <rekado@elephly.net>
-;;; Copyright © 2015, 2023 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2015-2018, 2020-2023 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Carlos Sánchez de La Lama <csanchezdll@gmail.com>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
@@ -889,15 +889,6 @@ using compilers other than GCC."
":")
"\nAM_CXXFLAGS = ")))))))
'())
- ,@(let ((version (package-version gcc)))
- (if (and (target-ppc64le?)
- (version>=? version "11")
- (not (version>=? version "12")))
- `((add-after 'unpack 'patch-powerpc
- (lambda _
- (invoke "patch" "--force" "-p1" "-i"
- (search-patch "gcc-11-libstdc++-powerpc.patch")))))
- '()))
;; Force rs6000 (i.e., powerpc) libdir to be /lib and not /lib64.
(add-before 'chdir 'fix-rs6000-libdir
(lambda _