summaryrefslogtreecommitdiff
path: root/gnu/packages/gcc.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-05-30 12:37:33 +0300
committerEfraim Flashner <efraim@flashner.co.il>2024-05-30 13:58:37 +0300
commitee8ff44519650706a563da96cf22b0f64dd22c34 (patch)
treeded187d78699fcb698a1294b96be59700696433b /gnu/packages/gcc.scm
parent86cab5c4bc436e1900bbc697eb12fbc177df24d6 (diff)
gnu: gcc-13: Remove unneeded patch for i586-gnu.
* gnu/packages/gcc.scm (gcc-13)[arguments]: When building for i586-gnu delete the inherited phase 'patch-hurd-libpthread as it exists upstream. Change-Id: I0837dcff325b15b6975b34dbd7268faaa223ecdd
Diffstat (limited to 'gnu/packages/gcc.scm')
-rw-r--r--gnu/packages/gcc.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index 0060ff7518..9dc6e10b42 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -808,6 +808,13 @@ It also includes runtime support libraries for these languages.")
"gcc-5.0-libvtv-runpath.patch"))
(modules '((guix build utils)))
(snippet gcc-canadian-cross-objdump-snippet)))
+ (arguments
+ (substitute-keyword-arguments (package-arguments gcc-11)
+ ((#:phases phases #~%standard-phases)
+ (if (target-hurd?)
+ #~(modify-phases #$phases
+ (delete 'patch-hurd-libpthread))
+ phases))))
(properties
`((compiler-cpu-architectures
("aarch64" ,@%gcc-13-aarch64-micro-architectures)