summaryrefslogtreecommitdiff
path: root/gnu/packages/geo.scm
diff options
context:
space:
mode:
authorLeo Prikler <leo.prikler@student.tugraz.at>2021-07-21 13:02:09 +0200
committerLeo Prikler <leo.prikler@student.tugraz.at>2021-07-23 12:41:01 +0200
commit4e19ad0fde26266a5e3a9ec6d73ad3bf88fc189d (patch)
tree81e53ad79089186ae9c0eba55e04b0ecfbf192fb /gnu/packages/geo.scm
parent785c96fbe162c55c46b7a14bbfe7ccade8f063f6 (diff)
gnu: gnome-maps: Update to 3.38.5.
* gnu/packages/geo.scm (gnome-maps): Update to 3.38.5.
Diffstat (limited to 'gnu/packages/geo.scm')
-rw-r--r--gnu/packages/geo.scm13
1 files changed, 11 insertions, 2 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 37be78edbf..8b71f5b03c 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -210,7 +210,7 @@ topology functions.")
(define-public gnome-maps
(package
(name "gnome-maps")
- (version "3.36.7")
+ (version "3.38.5")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -218,7 +218,7 @@ topology functions.")
name "-" version ".tar.xz"))
(sha256
(base32
- "09rgw8hq3ligap1zzjhx25q354ficpbiw1z9ramghhcqbpylsxdh"))))
+ "1llgzm2ni3iy31dznqkc81vadv0fpqgpz2l9zzrj5jshvyq0akgh"))))
(build-system meson-build-system)
(arguments
`(#:glib-or-gtk? #t
@@ -236,6 +236,15 @@ topology functions.")
(("@pkgdatadir@/org.gnome.Maps")
(string-append (assoc-ref outputs "out") "/bin/gnome-maps")))
#t))
+ (add-after 'unpack 'fix-broken-tests
+ (lambda _
+ ;; For some reason setting LC_ALL=C and LANG=C as done in the
+ ;; build system does not prevent these gratuitous commas from
+ ;; being inserted.
+ (substitute* "tests/utilsTest.js"
+ (("1001 m") "1,001 m")
+ (("1000 ft") "1,000 ft")
+ (("5282 ft") "5,282 ft"))))
(add-after 'install 'wrap
(lambda* (#:key inputs outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out"))