summaryrefslogtreecommitdiff
path: root/gnu/packages/geo.scm
diff options
context:
space:
mode:
authorWiktor Żelazny <wz@freeshell.de>2021-07-14 19:55:52 +0200
committerMathieu Othacehe <othacehe@gnu.org>2021-07-25 13:51:45 +0200
commit769326cf185c024c760931f35c6001c32c85b4a2 (patch)
tree749bffdb0b5da010fb12161e4fe803c44032bc31 /gnu/packages/geo.scm
parenta92dfbce30777de6ca05031e275410cf9f56c84c (diff)
gnu: Add marble-qt.
* gnu/packages/patches/marble-qt-add-qt-headers.patch: New patch. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/geo.scm (marble-qt): New variable. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages/geo.scm')
-rw-r--r--gnu/packages/geo.scm42
1 files changed, 41 insertions, 1 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 8b71f5b03c..5419f27d9a 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -9,7 +9,7 @@
;;; Copyright © 2018, 2019, 2020 Julien Lepiller <julien@lepiller.eu>
;;; Copyright © 2019, 2020, 2021 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2019, 2020, 2021 Efraim Flashner <efraim@flashner.co.il>
-;;; Copyright © 2019 Wiktor Żelazny <wzelazny@vurv.cz>
+;;; Copyright © 2019, 2021 Wiktor Żelazny <wzelazny@vurv.cz>
;;; Copyright © 2019, 2020 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2020 Christopher Baines <mail@cbaines.net>
@@ -2423,3 +2423,43 @@ web services. @code{geopy} makes it easy for Python developers to locate the
coordinates of addresses, cities, countries, and landmarks across the globe
using third-party geocoders and other data sources.")
(license license:expat)))
+
+(define-public marble-qt
+ (let ((release "17.08")
+ (commit "fc7166eeef784732033c999ba605364f9c82d21c")
+ (revision "1"))
+ (package
+ (name "marble-qt")
+ (version (git-version release revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "git://anongit.kde.org/marble")
+ (commit commit)))
+ (sha256
+ (base32
+ "0m0sf3sddaib7vc5lhbmh7ziw07p1hahg02f65sgfylyl5f5kj92"))
+ (patches (search-patches
+ "marble-qt-add-qt-headers.patch"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f ; libmarblewidget-qt5.so.28 not found
+ #:configure-flags
+ '("-DCMAKE_BUILD_TYPE=Release"
+ "-DWITH_KF5=FALSE")))
+ (native-inputs
+ `(("qttools" ,qttools)))
+ (inputs
+ `(("qtbase" ,qtbase-5)
+ ("qtsvg" ,qtsvg)
+ ("qtdeclarative" ,qtdeclarative)
+ ("qtwebkit" ,qtwebkit)
+ ("qtlocation" ,qtlocation)))
+ (home-page "https://marble.kde.org/")
+ (synopsis "Virtual globe and world atlas")
+ (description "Marble is similar to a desktop globe. At closer scale it
+becomes a world atlas, while OpenStreetMap takes the user to street level. It
+supports searching for places of interest, viewing Wikipedia articles,
+creating routes by drag and drop and more.")
+ (license license:gpl3))))