summaryrefslogtreecommitdiff
path: root/gnu/packages/geo.scm
diff options
context:
space:
mode:
authorFelix Gruber <felgru@posteo.net>2024-02-24 15:15:01 +0000
committerGuillaume Le Vaillant <glv@posteo.net>2024-02-26 11:43:36 +0100
commitcc7486cd9840917b3e7d7e00cec1022179863784 (patch)
tree4c2e75878b01a1dde9a172d6a511e0ba09180a4c /gnu/packages/geo.scm
parentb25b94335a3ee8d68d2145da8e5ea0325ecea451 (diff)
gnu: osm2pgsql: Update to 1.11.0.
* gnu/packages/geo.scm (osm2pgsql): Update to 1.11.0. [arguments]: Look for proj API version 6 to use recent proj versions. [inputs]: Remove proj-7; add cli11 and proj. Change-Id: If1f14e5c675865d4485b16aca6146f555cc16d5e Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu/packages/geo.scm')
-rw-r--r--gnu/packages/geo.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index aeb3a9fbd2..687effcace 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -1677,7 +1677,7 @@ based on the Osmium library.")
(define-public osm2pgsql
(package
(name "osm2pgsql")
- (version "1.9.2")
+ (version "1.11.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -1686,7 +1686,7 @@ based on the Osmium library.")
(file-name (git-file-name name version))
(sha256
(base32
- "198qcgl42pb8lk1bn41ncp8hc9gcg9k2p0ny42vak019w5l6jcj7"))
+ "135vqahlcrhwa3b9hfgbiqkzbbsjd4i79fp41cd0rp4zarcpi47p"))
(modules '((guix build utils)))
(snippet
;; Remove bundled libraries.
@@ -1694,20 +1694,21 @@ based on the Osmium library.")
(build-system cmake-build-system)
(arguments
(list #:tests? #f ;tests fail because we need to setup a database
- #:configure-flags #~(list "-DUSE_PROJ_LIB=4" ;use API version 4
+ #:configure-flags #~(list "-DUSE_PROJ_LIB=6" ;use API version 6
"-DWITH_LUAJIT=ON"
"-DEXTERNAL_LIBOSMIUM=ON"
"-DEXTERNAL_PROTOZERO=ON"
"-DEXTERNAL_FMT=ON")))
(inputs (list boost
bzip2
+ cli11
expat
fmt-8
libosmium
luajit
nlohmann-json
postgresql
- proj-7
+ proj
protozero
zlib))
(native-inputs (list pandoc python python-argparse-manpage))