summaryrefslogtreecommitdiff
path: root/gnu/packages/geo.scm
diff options
context:
space:
mode:
authorjgart <jgart@dismail.de>2023-01-02 19:39:05 -0600
committerLudovic Courtès <ludo@gnu.org>2023-01-30 23:39:23 +0100
commitd7552c36ce79dcef8ebc3f7ac97d23e9be9e9859 (patch)
tree0770f47dcb1860e6e23a3455f120f98221ee1fb2 /gnu/packages/geo.scm
parentd1e0a0528a8dbe8fb01c6c9ac02663388d17cbc0 (diff)
gnu: Add python-haversine.
* gnu/packages/geo.scm (python-haversine): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/geo.scm')
-rw-r--r--gnu/packages/geo.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 432903acc9..6402e56a0f 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -2826,6 +2826,36 @@ coordinates of addresses, cities, countries, and landmarks across the globe
using third-party geocoders and other data sources.")
(license license:expat)))
+(define-public python-haversine
+ (package
+ (name "python-haversine")
+ (version "2.7.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ ;; There are no tests in the PyPi archive.
+ (url "https://github.com/mapado/haversine")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0inxyj5n4jzgg5xiadqx9sk83gdx5ff989l9s04smdzbd3b8c0c8"))))
+ (build-system python-build-system)
+ (native-inputs (list python-pytest python-numpy))
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? inputs #:allow-other-keys)
+ (when tests?
+ (invoke "pytest")))))))
+ (home-page "https://github.com/mapado/haversine")
+ (synopsis "Calculate the distance between 2 points on Earth")
+ (description "This package provides functions to calculate the
+distance in various units between two points on Earth using their
+latitude and longitude.")
+ (license license:expat)))
+
(define-public gplates
(package
(name "gplates")