summaryrefslogtreecommitdiff
path: root/gnu/packages/geo.scm
diff options
context:
space:
mode:
authorClément Lassieur <clement@lassieur.org>2021-09-21 12:24:14 +0200
committerClément Lassieur <clement@lassieur.org>2021-09-21 17:25:26 +0200
commitf9fd3752f6956b5654884036823fde5ef235b51a (patch)
tree2acf0d9fb49316c79fbb6ba6f527e146d54a14df /gnu/packages/geo.scm
parentfd672f30d0ac88c62b3216fc3c7ec98eeec3ad39 (diff)
gnu: josm: Fix .desktop file.
* gnu/packages/geo.scm (josm)[arguments]: In 'install-share-directories' phase, change org-openstreetmap-josm-MainApplication to org-openstreetmap-josm-gui-MainApplication.
Diffstat (limited to 'gnu/packages/geo.scm')
-rw-r--r--gnu/packages/geo.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 791fd5f1b6..9d4a1a8955 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -1524,14 +1524,17 @@ to the OSM opening hours specification.")
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out"))
(share-directories '("applications" "icons" "man" "menu"
- "metainfo" "mime" "pixmaps")))
+ "metainfo" "mime" "pixmaps"))
+ (desktop "org.openstreetmap.josm.desktop"))
(for-each (lambda (directory)
(copy-recursively (string-append
"native/linux/tested/usr/share/"
directory)
(string-append
out "/share/" directory)))
- share-directories))
+ share-directories)
+ (substitute* (string-append out "/share/applications/" desktop)
+ (("josm-MainApplication") "josm-gui-MainApplication")))
#t))
(add-after 'install 'install-bin
(lambda* (#:key outputs inputs #:allow-other-keys)