summaryrefslogtreecommitdiff
path: root/gnu/packages/gimp.scm
diff options
context:
space:
mode:
authorVivien Kraus <vivien@planete-kraus.eu>2023-09-08 18:50:18 +0200
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2023-09-14 20:39:17 +0200
commit4beac7d95c84ea3be809030f942b8b71d155129e (patch)
treead177d1c287c695964dacd830fb09ec4284aa390 /gnu/packages/gimp.scm
parent0b4a20e448876667c2172b9f07346e1f0b7c605e (diff)
gnu: gegl: Update to 0.4.46.
* gnu/packages/gimp.scm (gegl): Update to 0.4.46. * gnu/packages/gimp.scm (gegl-0.4.44): New variable. * gnu/packages/gnome.scm (gnome-photos)[inputs]: Replace gegl with gegl-0.4.44. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
Diffstat (limited to 'gnu/packages/gimp.scm')
-rw-r--r--gnu/packages/gimp.scm27
1 files changed, 25 insertions, 2 deletions
diff --git a/gnu/packages/gimp.scm b/gnu/packages/gimp.scm
index b1ff08d652..45a739a3ae 100644
--- a/gnu/packages/gimp.scm
+++ b/gnu/packages/gimp.scm
@@ -215,7 +215,7 @@ provided, as well as a framework to add new color models and data types.")
(define-public gegl
(package
(name "gegl")
- (version "0.4.42")
+ (version "0.4.46")
(source
(origin
(method url-fetch)
@@ -228,8 +228,10 @@ provided, as well as a framework to add new color models and data types.")
(string-append "ftp://ftp.gtk.org/pub/gegl/"
(version-major+minor version)
"/gegl-" version ".tar.xz")))
+ (patches
+ (search-patches "gegl-compatibility-old-librsvg.patch"))
(sha256
- (base32 "0bg0vlmj4n9x1291b9fsjqxsal192zlg48pa57f6xid6p863ma5b"))))
+ (base32 "14p8n6vily0yp6gqafl2xy7d2rh1j48pcj0a7mglqxy83d4b5cyh"))))
(build-system meson-build-system)
(arguments
`(#:configure-flags
@@ -285,6 +287,27 @@ buffers.")
;; application and GUI binary gegl is licensed under GPL.
(license (list license:lgpl3+ license:gpl3+))))
+;; gnome-photos does not build against gegl 0.4.46 yet.
+;; See also <https://gitlab.gnome.org/GNOME/gnome-photos/-/issues/214>.
+(define-public gegl-0.4.44
+ (package
+ (inherit gegl)
+ (version "0.4.44")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (list (string-append "https://download.gimp.org/pub/gegl/"
+ (string-take version 3)
+ "/gegl-" version ".tar.xz")
+ (string-append "https://ftp.gtk.org/pub/gegl/"
+ (version-major+minor version)
+ "/gegl-" version ".tar.xz")
+ (string-append "ftp://ftp.gtk.org/pub/gegl/"
+ (version-major+minor version)
+ "/gegl-" version ".tar.xz")))
+ (sha256
+ (base32 "09k1sn4h0bakgmq2hgd1iamprngpr81ky3fd9446lh2ycd0xnk0a"))))))
+
(define-public gimp
(package
(name "gimp")