summaryrefslogtreecommitdiff
path: root/gnu/packages/gl.scm
diff options
context:
space:
mode:
authorAndy Wingo <wingo@pobox.com>2015-04-05 11:28:32 +0200
committerMark H Weaver <mhw@netris.org>2015-04-06 18:11:05 -0400
commit131ddf991fcbdeba48318555de56e40208f03ff5 (patch)
tree7b6b13093d3ee5a9129ee039cc9db4abbc9314f5 /gnu/packages/gl.scm
parentd16c9fd80fd094ee03135ba8db281022e1b1ab9a (diff)
gnu: Add libepoxy.
* gnu/packages/gl.scm (libepoxy): New variable. Modified-By: Mark H Weaver <mhw@netris.org>
Diffstat (limited to 'gnu/packages/gl.scm')
-rw-r--r--gnu/packages/gl.scm47
1 files changed, 47 insertions, 0 deletions
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index 66f172927f..f3e63180c6 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -418,3 +418,50 @@ extension functionality is exposed in a single header file.")
"Guile-OpenGL is a library for Guile that provides bindings to the
OpenGL graphics API.")
(license l:lgpl3+)))
+
+(define-public libepoxy
+ (package
+ (name "libepoxy")
+ (version "1.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/anholt/libepoxy/archive/v"
+ version
+ ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1xp8g6b7xlbym2rj4vkbl6xpb7ijq7glpv656mc7k9b01x22ihs2"))))
+ (arguments
+ '(#:phases
+ (alist-cons-after
+ 'unpack 'autoreconf
+ (lambda _
+ (zero? (system* "autoreconf" "-vif")))
+ (alist-cons-before
+ 'configure 'patch-paths
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((python (assoc-ref inputs "python"))
+ (mesa (assoc-ref inputs "mesa")))
+ (substitute* "src/gen_dispatch.py"
+ (("/usr/bin/env python") python))
+ (substitute* (find-files "." "\\.[ch]$")
+ (("libGL.so.1") (string-append mesa "/lib/libGL.so.1"))
+ (("libEGL.so.1") (string-append mesa "/lib/libEGL.so.1")))
+ #t))
+ %standard-phases))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool)
+ ("pkg-config" ,pkg-config)
+ ("python" ,python)))
+ (inputs
+ `(("mesa" ,mesa)))
+ (home-page "http://github.com/anholt/libepoxy/")
+ (synopsis "A library for handling OpenGL function pointer management")
+ (description
+ "A library for handling OpenGL function pointer management.")
+ (license l:x11)))