summaryrefslogtreecommitdiff
path: root/gnu/packages/gl.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-08-09 14:16:01 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-08-09 17:47:47 +0300
commit2e16a2230188a04d05665e81e346ecf9df9810ee (patch)
tree6b0f087c2bd685d5df8b219e348ab43d7b000f90 /gnu/packages/gl.scm
parent57e59eddfbdfe2316e5f619cff9cdc49fbedeb7a (diff)
gnu: mesa: Skip additional test on powerpc-linux.
* gnu/packages/gl.scm (mesa)[arguments]: Add another substitution for powerpc-linux to custom 'disable-failing-test phase.
Diffstat (limited to 'gnu/packages/gl.scm')
-rw-r--r--gnu/packages/gl.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index d694c0a7cb..5f626ceb96 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -381,7 +381,10 @@ also known as DXTn or DXTC) for Mesa.")
(("'u_format_test', ") ""))
;; It is only this portion of the test which fails.
(substitute* "src/mesa/main/tests/meson.build"
- ((".*mesa_formats.*") ""))))
+ ((".*mesa_formats.*") ""))
+ ;; This test times out and receives SIGTERM.
+ (substitute* "src/amd/common/meson.build"
+ (("and not with_platform_windows") "and with_platform_windows"))))
("i686-linux"
;; Disable new test from Mesa 19 that fails on i686. Upstream
;; report: <https://bugs.freedesktop.org/show_bug.cgi?id=110612>.