summaryrefslogtreecommitdiff
path: root/gnu/packages/gl.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-06-23 19:22:23 +0200
committerMarius Bakke <marius@gnu.org>2022-06-23 19:55:43 +0200
commita6bc7baa5430f2388ea6a134146908e830ef3a21 (patch)
tree5499f2ce4609e71756c370fa4a4b79e6362c38ec /gnu/packages/gl.scm
parent60f17c197d97fa12ab4924c3c8dd14d51252d015 (diff)
gnu: freeglut: Update to 3.2.2.
* gnu/packages/gl.scm (freeglut): Update to 3.2.2. [source](uri): Switch to new primary download location. [source](patches): Remove. * gnu/packages/patches/freeglut-gcc-compat.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly.
Diffstat (limited to 'gnu/packages/gl.scm')
-rw-r--r--gnu/packages/gl.scm9
1 files changed, 4 insertions, 5 deletions
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index 4ee5f85b32..fcc110e6bf 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -105,16 +105,15 @@ as ASCII text.")
(define-public freeglut
(package
(name "freeglut")
- (version "3.2.1")
+ (version "3.2.2")
(source (origin
(method url-fetch)
(uri (string-append
- "mirror://sourceforge/freeglut/freeglut/"
- version "/freeglut-" version ".tar.gz"))
- (patches (search-patches "freeglut-gcc-compat.patch"))
+ "https://github.com/FreeGLUTProject/freeglut/releases"
+ "/download/v" version "/freeglut-" version ".tar.gz"))
(sha256
(base32
- "0s6sk49q8ijgbsrrryb7dzqx2fa744jhx1wck5cz5jia2010w06l"))))
+ "0l3s57zw51fy3mn5qfdm4z775kfhflgxppanaxmskfzh5l44m565"))))
(build-system cmake-build-system)
(arguments
'(#:tests? #f ;no test target