summaryrefslogtreecommitdiff
path: root/gnu/packages/glib.scm
diff options
context:
space:
mode:
authorKei Kebreau <kkebreau@posteo.net>2019-12-21 23:19:13 -0500
committerKei Kebreau <kkebreau@posteo.net>2020-04-18 16:51:28 -0400
commit9064cde1a9332006f99000d303374239054d9b4b (patch)
tree30b1fdb094f75d7644350ca9dc7e35c2f3784ac9 /gnu/packages/glib.scm
parent0fda99c572617bfa85d11f67ab0be824474004d8 (diff)
gnu: telepathy-glib: Disable failing tests.
* gnu/packages/glib.scm (telepathy-glib)[arguments]: Add phase to disable failing tests. (cherry picked from commit 9049e4d808f241dd88ddcb6a0f74b0766624fb08)
Diffstat (limited to 'gnu/packages/glib.scm')
-rw-r--r--gnu/packages/glib.scm13
1 files changed, 12 insertions, 1 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index 185066ade9..1e9941945c 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -825,7 +825,18 @@ up the Gnome environment, and are used in many unrelated projects.")
;;
;; EOFError: EOF read where object expected
;; make[2]: *** [Makefile:1906: _gen/register-dbus-glib-marshallers-body.h] Error 1
- #:parallel-build? #f))
+ #:parallel-build? #f
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'disable-failing-tests
+ (lambda _
+ ;; None of the tests below are able to find the org.gtk.vfs.Daemon
+ ;; service file provided by gvfs.
+ (substitute* "tests/dbus/Makefile.in"
+ (("test-contacts\\$\\(EXEEXT\\)") "")
+ (("test-file-transfer-channel\\$\\(EXEEXT\\)") "")
+ (("test-stream-tube\\$\\(EXEEXT\\)") ""))
+ #t)))))
(native-inputs
`(("glib" ,glib "bin") ; uses glib-mkenums
("gobject-introspection" ,gobject-introspection)