summaryrefslogtreecommitdiff
path: root/gnu/packages/glib.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-06-02 23:40:19 +0200
committerMarius Bakke <marius@gnu.org>2020-06-02 23:41:35 +0200
commit9a46e0dd843a2f4c832f74e9a503e7200c934eb7 (patch)
treebdd1a84911e1bf91686ea99a3aa2410a6a62cf53 /gnu/packages/glib.scm
parent395659d86d98afaba4d311ca5618f49a4548f6ae (diff)
gnu: dbus: Fix CVE-2020-12049.
* gnu/packages/patches/dbus-CVE-2020-12049.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/glib.scm (dbus/fixed): New variable. (dbus)[replacement]: New field.
Diffstat (limited to 'gnu/packages/glib.scm')
-rw-r--r--gnu/packages/glib.scm10
1 files changed, 10 insertions, 0 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index 12ba6e939b..94dc6adf6f 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -88,6 +88,7 @@
(package
(name "dbus")
(version "1.12.16")
+ (replacement dbus/fixed)
(source (origin
(method url-fetch)
(uri (string-append
@@ -164,6 +165,15 @@ or through unencrypted TCP/IP suitable for use behind a firewall with
shared NFS home directories.")
(license license:gpl2+))) ; or Academic Free License 2.1
+;; Replacement package to fix CVE-2020-12049.
+(define dbus/fixed
+ (package
+ (inherit dbus)
+ (source (origin
+ (inherit (package-source dbus))
+ (patches (append (search-patches "dbus-CVE-2020-12049.patch")
+ (origin-patches (package-source dbus))))))))
+
(define glib
(package
(name "glib")