summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-05-05 15:50:11 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-05-07 19:29:43 +0300
commit0867ffbc622301d755989a3e150111734dfa4418 (patch)
tree877d20510b03ed7262f3651063e184be7f4a1112 /gnu/packages/gnome.scm
parent956672129235b8d6f44a9bb4e284f58ddb44d4e9 (diff)
gnu: librsvg-for-system: Choose librsvg based on package support.
* gnu/packages/gnome.scm (librsvg-for-system): Adjust the logic to choose which librsvg based on which version is supported.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index bf041e32c6..754bb668ba 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -3696,7 +3696,7 @@ diagrams.")
;; Since librsvg 2.50 depends on Rust, and Rust is only correctly supported
;; on x86_64, aarch64 and riscv64 so far, use the ancient C version on other
;; platforms (FIXME).
- (if (string-prefix? "x86_64-" system)
+ (if (supported-package? librsvg)
librsvg
librsvg-2.40))