summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorVivien Kraus <vivien@planete-kraus.eu>2023-11-14 01:01:22 +0100
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2024-01-01 21:06:05 +0100
commit12c2307451f3d60f1303fd53927bd8428849cc58 (patch)
tree3bc0d85d4456d96e633f6a833b9444b198b44f63 /gnu/packages/gnome.scm
parent3030e4104e8330f0591169e16fd9727b1bd56aeb (diff)
gnu: cheese: Update to 44.1.
The build system changed how it disables icon-theme.cache. * gnu/packages/gnome.scm (cheese): Update to 44.1. [#:phases]<skip-gtk-update-icon-cache>: Update. Change-Id: I95044d29da019345d14b5fe8f1671f0f7046fba3 Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 8fd4619236..f64c502cdb 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -11409,7 +11409,7 @@ photo-booth-like software, such as Cheese.")
(define-public cheese
(package
(name "cheese")
- (version "43.0")
+ (version "44.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -11417,7 +11417,7 @@ photo-booth-like software, such as Cheese.")
version ".tar.xz"))
(sha256
(base32
- "02vzcvk2s6cwvdw6v6qmlq3znamy6zwv7l6nlbqjfwrj7i54qmvl"))))
+ "13pnz35yvwvmk1iyhcp1a94yal4rh610rxmsp3rdsm4yr728a8az"))))
(arguments
(list #:glib-or-gtk? #t
#:phases
@@ -11425,8 +11425,9 @@ photo-booth-like software, such as Cheese.")
(add-after 'unpack 'skip-gtk-update-icon-cache
(lambda _
;; Don't create 'icon-theme.cache'.
- (substitute* "meson_post_install.py"
- (("gtk-update-icon-cache") (which "true")))))
+ (substitute* "meson.build"
+ (("gtk_update_icon_cache: true")
+ "gtk_update_icon_cache: false"))))
(add-after 'install 'wrap-cheese
(lambda* (#:key inputs outputs #:allow-other-keys)
(wrap-program (search-input-file outputs "bin/cheese")